Poor beastie is too busy to say that it's working hard

Just in case anyone is interested…

Screenshot taken on Debian 9 of gui and top on a Raspberry Pi Zero W.

Top shows the pi hard at work, mostly with syncthing. Guishows 0% cpu

Looks like the uptime is wrong as well?

Not a lot

Aah process uptime, not system uptime. Ignore me. I thought it might be an indication the UI wasn’t updating.

I don’t seem to get anything other than 0% cpu anywhere.

Newly installed SyncTrayzor on Win10.

Anyone else getting this?

I get reasonable values on FreeBSD and Darwin, but zero on the one Linux device I have. So something seems broken there. Which is odd as it’s the same code that runs on the other two platforms. But I did rewrite this a couple of releases back and probably broke it then.

It’s not just a poor, under-powered pi anymore.

Whatever I do in debian, raspbian or windows 10, CPU shows as 0%.

Am I really the only one experiencing this?

I would raise a github issue…

Just seen @calmh post as I’m typing this.

So I’m not going mad.

Please change title of the thread to “Syncthing implements perpetual motion!”


The problem seems to be when running with -no-restart. But not when accomplishing the same by setting STNORESTART=1 in the environment. I’ll try to fix this for the 0.14.30 rc tomorrow.