Permission Denied

Hey there everyone. Running Syncthing from the .deb repository as detailed here:

Spun up Syncthing and I’m trying to use it to syncronize a copy of my OpenHAB configuration folder at /etc/openhab2. No matter what I do it won’t let Syncthing write the .stfolder file for that share, saying:

Failed to create folder marker: mkdir /etc/openhab2/.stfolder: read-only file system

I’ve tried giving that directory wide open perms with chmod -R 777 /etc/openhab2. I’ve even started the systemd service as root… still get the same thing… what gives? I’m running out of ideas… Can anyone help me figure this out? Thanks in advance!

There are Harding options in the systemd service to prevent write access to system directories. You’ll need to remove those. Or, probably better, store the synced files outside of etc and symlink to them.


This solved it! Changed ProtectSystem from full to true. Thanks a bunch!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.