Overide Changes button behavior

OK, here are two files Syncthing claims to be out of sync.

admin@RMNDiskStation:/volume1/Hephaestus Station/Media/calibre_audiobook/Amir Aczel/Entanglement (149)$ stat Entanglement\ -\ Amir\ Aczel.zip File: ‘Entanglement - Amir Aczel.zip’ Size: 170637518 Blocks: 333296 IO Block: 4096 regular file Device: fd00h/64768d Inode: 558071839 Links: 1 Access: (0666/-rw-rw-rw-) Uid: ( 1026/ Scott) Gid: ( 100/ users) Access: 2016-08-29 17:33:58.000000000 -0700 Modify: 2016-08-29 17:33:58.000000000 -0700 Change: 2017-06-06 14:38:36.663930732 -0700 Birth: -

and

pi@books002:/media/storage/calibre_audiobooks/Amir Aczel/Entanglement (149) $ stat Entanglement\ -\ Amir\ Aczel.zip File: ‘Entanglement - Amir Aczel.zip’ Size: 170637518 Blocks: 333288 IO Block: 4096 regular file Device: 801h/2049d Inode: 6422630 Links: 1 Access: (0775/-rwxrwxr-x) Uid: ( 1000/ pi) Gid: ( 1000/ pi) Access: 2017-06-02 17:18:04.698382000 -0700 Modify: 2016-08-29 17:33:58.000000000 -0700 Change: 2017-06-06 11:26:23.931045764 -0700 Birth: -

Here is the Diff Result:

admin@RMNDiskStation:/volume1/Hephaestus Station/Media/calibre_audiobook$ diff Amir\ Aczel/Entanglement\ (149)/Entanglement\ -\ Amir\ Aczel.zip _CCC\ SafetyNet/Entanglement\ -\ Amir\ Aczel.zip admin@RMNDiskStation:/volume1/Hephaestus Station/Media/calibre_audiobook$

I assume that means there are no differences

The permissions are different, which causes it to show up out of sync. You potentially have some funky filesystem (FAT/exFAT) that does not support proper permissioning.

You potentially have some funky filesystem (FAT/exFAT) that does not support proper permissioning.

nope, changed to ext4 (hence did not check ‘ignore permissions’ in this case)

The only difference this time is that I preloaded that flash drive from another linux box, as it is very very slow to scan (takes about 18 hours to scan 65GB) That was not the difference last time.

I’ve checked “ignore permissions” and override, lets see if that clears it up

pi@books002:/ $ sudo blkid -o list /dev/sda1 ext4 PNY128 /media/storage 11a2c971-d467-46b1-8002-4a4f5a313a53

It’s not clear which side is changing the permissions though, it could be the other side. You can override and run strace on syncthing, I suspect you won’t see us changing permissions.

Change times are different as well, if that makes any difference.

The permissions must be different between the Pi (which the webserver must have read access to) and the Synology which doesn’t have a webserver. “Ignore Permissions” is the answer?

I think change times should be overwritten as the MD5 checksum should match

That’s what you’d want, not what everyone would want. Regardless, from what you’ve described it seems nothing is being downloaded

That’s what you’d want, not what everyone would want.

fair point, though a fair counter would be an advanced option to do so (and it should be off by default). This is another part of the issue #62 debate :wink:

^^(link included for people not familiar. I wasn’t)

Regardless, from what you’ve described it seems nothing is being downloaded That would seem to be the case, though with as long as it takes to recalculate the checksum on 65GB of files on a really slow drive on a really slow computer, it might be faster. Not Syncthing’s problem however.

The solution here: In a (as close as we can get to) Master/Slave situation, only populate the sync folder from Syncthing, not by any other method. That way leads to confusion.

It’s repopulating now, should take about 50 hours.

Let’s close this thread as solved.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.