Out of Sync files

I’ve had a remote VPS running Ubuntu and local DS918+, both syncthing apps run in docker. After a folder delete and re-add, it shows out of sync files after days of usage. The files are deleted in the remote but I’m sure it’s already synced down to local. Both have ignore delete checked and remote is send-only and local is receive-only. I’ve tried ignore permissions on local and Send Full Index On Upgrade on both, but all didn’t work. Here is debug archive attached support-bundle-4ZGBK2Q-2023-04-23T102217.zip (23.7 KB) support-bundle-TVHIA7Y-2023-04-23T022322.zip (22.1 KB)

Have you taken a look at the list of 90 items that are out of sync on device DS918+?

With ignore delete checked, device DS918+ will eventually be out of sync when items are deleted from OsakaARM2.

Or in other words, if there’s a file named music.mp3 on OsakaARM2 and it’s mirrored to DS918+, then later deleted from OsakaARM2, from the point of view of DS918+ everything is up to date, but OsakaARM2 will see that music.mp3 hasn’t been deleted on DS918+ (because DS918+ is ignoring the delete request), so OsakaARM2 considers DS918+ to be out of sync.

Yes, the out of synced items were all deleted in remote server OsakaARM2, but already synced to local DS918+. I thought if ignore delete checked, this won’t be tagged as out of sync, and as I remember it worked fine without out of sync before but I can be wrong. If this is just a feature, I’ll just ignore that. I’ve already updated to the newest version, but accidently the DS918+ lost all data. I’m reindexing all right now(the reason is a little bit tricky, I thought the config folder was /config so I bind a local folder to it, but I just found that it should be /var/syncthing/config, but it was working without error)

It has been noted various time here on the forums and in the docs that ignoreDelete is not recommended for use. Permanent out-of-sync is a side effect of the ignore delete option (see the docs link above).


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.