Out Of Memory -> Panic.Log


(totoba) #1

Linux X64 Debian Testing 12GB Ram

https://filebin.net/t620ia3o3qzc3lfq/panic.log

I removed first parts where it mentions my shares for privacy.

I should not be running out of memory. Before I start syncthing I have like 6GB of actual memory free.


PANIC - Out of memory while [Overrride Changes]
(Jakob Borg) #2

It’s running out of memory allocating space for weak hashes while syncing. (At least that’s the allocation that caused the failure, although lots of memory may have been used by something else, we can’t tell from the trace.) Presumably you have a fairly large file that needs syncing? I can think of one corner case that can cause this… There is a work around we can try to confirm. You can disable weak hashes by setting weakHashTresholdPct to 101 in Advanced > Folder.

You can also try this build if you like, which may fix it:

https://build.syncthing.net/job/syncthing-pr/3286/

In a few minutes, when it completes.


(totoba) #3

The file in quaestion was not large at least it was not too large. It was 250 mb( the largest file in that particular share), and yes setting weakhash to 101 finally fixed the file that was not syncing for a week.

I saw Syncthing using something like %35 of my physical memory (12GB) around that time, I checked it because the UI was constantly timing out. So it was syncing that was eating my my avail memory. It never gets that high generally.

As far as I can tell things got smoother after the new setting.

Please see this one Poor performance on big file and the post I replied to.


(Kluppy) #4

This should be fixed in 14.20. have you upgraded yet?


(totoba) #5

Well it seems like it upgraded last night already after I resolved the issue manually with the weakhash setting.


(totoba) #6

@calmh

Please see this post for my replies. It seems like the weakhash setting resolved the issue with the exact same file on my other device (windows Laptop)


(system) #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.