One folder won't sync

I’m new to Syncthing and have 4 matching folders on my laptop and desktop Linux machines setup to sync. I have them set on my laptop as send only. Three of the folders work as expected; new or modified files are synced to my desktop from the base folders and all subfolders of the base folders, but one folder, ~/Documents does not sync new or modified files from the base folder.

To ignore subfolders I have .stignore set as: !/Documents * However with that or with .stignore empty nothing gets copied or updated from ~/Documents and the output of global and local files always shows 0 files, 0 bytes on both machines. I created the folders and they have no special attributes or permissions, but no matter what I try they won’t sync. Suggestions?

If you share ~/Documents, !/Documents inside .stignore would unignore ~/Documents/Documents.

Ignoring subdirectories should work like this:


or maybe this:


this would still sync the dirs, but no content

Thanks for your reply. I tried your suggestions but the folder ~/Documents still doesn’t sync. Now however the output does show local and global files and sizes. I ignore the subfolders because they contain Gb worth of music files I don’t need synced, but even if I leave .stignore empty and let it sync the subfolders (which takes forever) it still doesn’t sync the base folder (Documents).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.