Nodes incorrectly syncing via WAN

I have three nodes on the LAN, all of which can syncthing to each other directly via the LAN. All of them are using 0.10.5. Mix of Win 7 / Win Vista machines.

Sometimes the nodes will connect to each other over the WAN. This has the result of significantly slowing down the transfer speeds and saturating my WiFi and WAN with hilarious results (insert ASCII smiley here)

If I restart syncthing on any one of the nodes, it will sometimes connect via LAN, sometimes by WAN. All nodes use “dynamic addresses” in syncthing, which is necessary as they do not have fixed IP addresses on the LAN.

1 Like

This is probably a timing problem, where the devices try to connect before they have seen each others’ local announcements and thus use the global server. It should be fixed. A workaround in the meantime could be to disable global announcements on some or all of the devices, unless they must actually be reachable from the outside as well.

1 Like
1 Like

Thanks - I’d done a search but didn’t come up with that one, assumedly because it’s the bug of the devil!