Newbie problems

Hello. Completely new to syncthing and having some set up issues. I have a ubuntu file server and multiple android phones running syncthing. The intention is to run it over LAN only. Global discovery and Relaying are disabled. Setup has been done using tcp ip. The server sees both phones but each phone tells me the server is reporting an unexpected ID. Firewall is temporarily disabled to eliminate that as the source (although port 22000 was open anyway). The intention is to configure it to back up my wifes many many many daily pohotos of our kids with minimal effort on her part.

Any advice appreciated

Can you post screenshots of the Syncthing Web GUI from all devices? On Android, you can access it using the left slide-out menu. Please make sure the hard-coded IP addresses are included.

Just a side note, but local discovery is currently broken in newer Android versions. It shouldn’t matter in your case if you’ve really hard-coded the addresses, but it’s just something to keep in mind.

will do

Thats the server settings. Il post screen shots of my phone in a few minutes.

my phone - my wife is asleep - hers is near identical with a different static ip and ID

Sods law, after restarting everything the server stopped seeing the phone - just iun time for screenshots

Please correct me if I’m wrong, but the configuration on the screenshot below seems wrong.

I assume the IP displayed here is supposed to be for the server. However, it appears that is the phone’s IP. Shouldn’t the address be set to instead?


Looking at the screenshots again, it seems that you’re actually editing device defaults and inputting the IP address there. That’s not what those settings are for. They’re used when adding new devices to override Syncthing defaults with your own pre-configured options.

You shouldn’t touch those, and instead just click the “Edit Device” button under each remote device and add its IP address there.

i scincerely hope it been that simple. I will be delighted if this a rookie error. il make the changes and let you know.

defaults restored and manual ip addressed added in edit device section

Yeah, so that normally should work. Not a networking expert here, but it seems that you’re using two different IP ranges (192.168.68.x and 192.168.1.x). Are you sure the devices on each of them can actually see and connect to one another?

May be related:

im using a mesh network. Wireless clients are routed through the deco system. Same subnet. Server is hard wired in. It was seeing the phones until i successfully broke that too lol

I really appreciate your help. If its network related, i am much more comfortable there. Il get some kip and start the next round in the morning. Cheers again

I am sticking out my neck and saying: I have never really understood why some want to limit to LAN only. You are just making it hard for yourself. :slight_smile: Enable global discovery and relaying and things will always work, no matter what!

You make a good point. I’m just being a speed snob. 2.5mb/sec transfer relayed for me Vs 30mb/s lan

Clearly not all hero’s wear capes. Once you confirmed it was set up correctly it took 10 minutes to identify and fix the network problem. Thanks again

1 Like

Glad I could help :slight_smile:.

Just for the record, normally Syncthing should connect directly without using relays, etc. and without hard-coding IP addresses even if all those settings are enabled. If it doesn’t, then something probably is wrong with the network configuration. In the case of Android though, it does require global discovery specifically in order to be able to find local IP addresses as well. Normally, local discovery is enough.

In other simpler words: Out of the box (with default settings) you get local data transfer when devices are on the same network, plus that sync works when not on the same network as well.

The only method to obtain total security against Internet threats is to simply not use the Internet at all.

Not much potential for firewall misconfiguration when you don’t even have a WAN to be firewalled against. :upside_down_face:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.