Need to allow newer config for GUI to work, it resets my dashboard my computer ID everytime

Hello,

I’ve been trying to make Syncthing work but I’ve been having some issues, I’m trying to sync a repository between my laptop (linux mint) and my phone (android). When trying to access the GUI on my laptop, it’s never able to connect, until I use

syncthing -allow-newer-config

to make it listen to 0.0.0.0:8384.

This creates a new dashboard every time with a new ID and nothing saved. I’ve tried the setup between my windows computer and phone and every thing works fine without issues.

The problem is specific to my laptop but I don´t know what causes it. This problem appeared right on my first install of SyncThing so I don’t think I’ve messed anything up. I’ve just replaced the localhost adress for the GUI in the config file and nothing else.

PS : I’m a linux newbie and not a developer, but I’m not afraid of terminal, please bear with me if I don’t understand everything

Something doesn’t sound right. How have you installed Syncthing specifically? If it’s a version from your OS’s repository, then I would suggest to uninstall everything, and then start from scratch following the instructions from https://apt.syncthing.net.

Also, you should be able to access the GUI using http://127.0.0.1:8384 out of the box. Of course, this is true only when running Syncthing locally. If you want to access, e.g. Syncthing on Android from your laptop, then you’d have to change the GUI address in the Android app settings to 0.0.0.0:8384. The same is true for the other direction.

Anyhow, if I were you, I’d try to clean all remnants of your current Syncthing installation, re-install using the up-to-date binaries from the official Syncthing repository, and then try to access the GUI again. If there are still problems, please post screenshots of what you’re seeing on the screen exactly.

Tried reinstalling it again with with this method (which is the same I used, but I might’ve not been careful enough)

Same problem happened, syncthing can’t listen to 127.0.0.1:8384, firefox says “unable to make connection”.

I’ve installed through syncthing GTK now and works no problem, I really don’t see what I did wrong and sadly can’t provide much insight on the problem…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.