multicastBeacon: Failed service

2021/01/10 19:48:22 multicastBeacon: Failed service ‘Service@0xc00053a600 created by multicastBeacon@0xc0005720f0/writer’ (1.000000 failures of 2.000000), restarting: true, error: write udp6 [::]:56463->[ff12::8384]:21027: wsasendto: A socket operation was attempted to an unreachable host.

I tried to google for this error in my log-console without success. Any ideas?

Not really, but it it’s mostly harmless (no local discovery over IPv6).

I have the same errors in log. Can i disable IPv6 local discovery? I found the option localAnnounceMCAddr but I don’t know what to write in it to disable local discovery. If i leave the field blank i get the error

IPv6 local discovery: address disable: missing port in address

I don’t think you can. What systems are you guys running that don’t have IPv6? It’s not like you need actual v6 connectivity to the world, it just needs to be enabled on the computer. This should be the default since … foreverish?

1 Like

I also noticed this in my logs.

@calmh to answer your question, anyone with a /etc/sysctl.conf like this:

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1 

… which includes me.

Sure, but then it’s intentional so that seems okay.

2 Likes