Moving to Go 1.5 as the minimum supported compiler

We currently support building with Go 1.3, released June 2014. There are some caveats and it’s not convenient as we use a vendoring mechanism only supported in Go 1.5+. Go 1.7beta1 was just released.

I propose that when Go 1.7 is released, we update our requirements to state that the minimum supported Go version is 1.5. This gains us a few convenience methods in the standard library and the new for range syntax that sometimes trip people up.

The only reason we’ve maintained compatibility for this long is because we could, and because some distros bundle old crap compilers. But I don’t see that being an issue for people who really want to build Syncthing, and the ones who don’t can just download a binary.

The old standard libraries have security issues anyway and should not be used.