macosx-launchd syncthing.plist using home folder on another drive is not working


I’ve followed the non homebrew directions as closely as I could, but I still can’t seem to get syncthing to load automatically at boot. I’m trying to install syncthing on a mac, but I’m having trouble configuring the syncthing.plist file. My home directory is located on a separate drive that has a space in the name which I think might be causing the problems. I’ve updated the plist file to point to my user directory. Example would be instead of “/Users/mdrv6”, I changed it to “/Volumes/Users\ HD/Users/mdrv6” where my home directory actually is. Notice, I also escaped out the space in the location.

Still no luck.

I find it’s convenient to symlink /Users/Volumes/Users HD when doing things like that, then pretend it’s just business as usual. Not that it’s clear to me why this would be a problem to begin with, though. Perhaps some extra quoting or something is required in the plist file.

Thank you @calmh. I was able to get it to work. As a second to last resort I symlinked my home folder, and it did end up working. I couldn’t leave well enough alone, so I dug more. When I looked into my Volumes folder (hidden by default in the finder), I saw that syncthing actually tried to create a “Users\ HD” folder. Even though I already tried not escaping out the space initially, this time when I tried it worked. Maybe I had a typo the first time.

Long story short: you don’t need to get all fancy when dealing with spaces.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.