MacOS: Can’t find out what notification is or what caused it?

I have Syncthing working on 2 newer MacMinis and I have just updated Synthing on both systems. On one I see no notification or warning or anything like that. On the menu icon, I see only the normal Syncthing icon and it’s running: Screenshot 2024-01-06 at 2.57.55 PM

So it’s there, it’s working, it’s up to date and so on. In the web interface, everything is up to date.

On the 2nd system, I have a persistent badge, but it’s so small, I can’t tell what it’s trying to tell me. I suspect it’s a ‘1’ in the badge, indicating one notification for me. In the web interface, everything shows synced and up to date. When I go to the Syncthing menu, I get this:

Screenshot 2024-01-06 at 2.56.06 PM

I’ve picked “Restart” several times and it makes no difference.

What I’d like to know:

  1. What’s wrong and where would I go to find that out? Nothing in Preferences or in the web interface reports just what is wrong.
  2. How can the service be running and yet offline?
  3. How can it sync between the two systems and be offline? (I changed one directory from “Receive Only” on the troublesome system and it promptly connected to the other system and synced data, but it was still listed as Offline.
  4. If it’s offline, how does it know everything is up to date, as indicated in the web interface?
  5. How do I fix this?

I don’t need numbers by each answer, I’m just trying to break it down into parts. An overall answer - anything would help. It seems like the two systems are staying in sync, but this particular one reports it’s offline.

Syncthing is set to run when I login.

Bump.

Any chance I could get some help with finding out what the notification I’m getting is for and what is not working?

Admins - maybe there’s a way to change the topic to something like, “Can’t find out what notification is or what caused it?” so it may get a bit more attention?

My understanding is that “Running (offline)” means that Syncthing is running, but the syncthing-macos wrapper can’t talk to it. Perhaps due to an incorrect API key?

2 Likes

I have no experience with the MacOS wrapper, but judging from the screenshots, I’d say one instance is “offline”, that’s the big difference. That could mean it has no connection to any remote device, or the wrapper cannot communicate with the Syncthing backend. The latter sounds familiar, as there were some other topics recently about the API Key not being read out properly on MacOS.

Maybe @jerryjacobs can help with the icon interpretation?

1 Like

Just a note that it’s not just about icon interpretation. If there is a notification pending, I should be able to see it somewhere, but within the app menus, the preferences window, and the web interface, there is no clear place to go to read pending notifications.

While the immediate problem is solved, there are other issues here that seriously need to be addressed.

Solution: I checked the API Key in Preferences and in the web interface. They did not match. I could not paste the one in preferences to the web interface, so I pasted the one in the web interface into the preferences and pressed “Test,” which had red dot by it. It tested and turned it to a green dot. I restarted.

The original incorrect API key was still in preferences. I repasted - this time I remembered to hit afterwards. It tested okay, I restarted, and the icon badge went away.

So the quick fix is to copy the API key from the web interface, paste it into prefs, be sure to hit, return>, so the GUI saves the new value, then press “Test” just to be sure. The dot next to “Test” should change from red to green.

Still a problem: There is NO documentation on this. I’d try to fix it in a wiki somewhere, but I have NO freaking idea just what was wrong, other than the API key. There is NOTHING that comes up under any searches to tell me why I have a notification badge on the Syncthing menu icon in my menu bar. (Not on Mac, not on any OS - there is NO documentation on why you’d get any kind of badge on the icon.) Also, NO documentation on the dot colors next to “Running” in the menu. I had orange. Why an orange dot? Because something wasn’t working. What wasn’t working? I had no idea because there is no documentation on this!

I would be more than willing to help document these things, but I don’t know what could cause an orange dot (is it just this one issue?) or any other color dot or what the icon badges are and what they mean. (I’m still wondering if the badge I got was a “1” or an exclamation point.) So I’d need to know where to go to discuss this documentation issue and what needs to be done to fix it. Can someone point me in the right direction or tag the appropriate person to discuss this with?

You’re using syncthing-macos for the notification thing, which is an extension/wrapper to Syncthing. There’s a README in GitHub - syncthing/syncthing-macos: Official frugal and native macOS Syncthing application bundle but I don’t think it covers notification colours specifically; I think they are mostly intended to be self explanatory, or more generally “click it to find out, if it’s not green”. You can contribute to the docs there, or could create a new article somewhere on docs.syncthing.net if that seems appropriate.

It’ll be a day ort wo before I can go over the docs on GitHub. Sounds like even there, some important info is not provided. I’m interested in helping, the issue is I don’t feel I can create information when I don’t have a solid source for it. What are the chances, if I ask the devs involved, I can get a good answer on something like the dot colors and notification icons on GitHub?

I’m pretty sure the main developer will know how it works and whether your suggested docs additions will be correct and useful. And it’s open source, so you can check the code as well to find out when something is displayed. Maybe not so easy for someone who hasn’t developed MacOS apps before.

The “badge” you’re talking about is just an indicator that something is not normal, and you should open up the menu to find out what. In almost all cases, it will lead you to a notification banner in the Web GUI. But this special case is that the wrapper cannot even talk to the backend because of the wrong API key, so it can’t find out the error message either.

API key mismatches are a known issue currently under investigation: ApiKey defaults not in sync with config.xml, autodetect and notify user · Issue #210 · syncthing/syncthing-macos · GitHub

Well, as they say, the best way to get the right answer on the internet is not to ask a question; it’s to post the wrong answer. If you were to contribute something and it was incorrect I’m sure someone would feel compelled to fix it and voila now we have documentation.

<bold>Syncthing macOS author and maintainer hopping in this discussion<bold>.

As @acolomb mentions this has recently happend in github issue #210 (again). Currently on first install the macOS wrapper synchronizes the API key from the config.xml to the macOS applications defaults store. For some reason when using the macOS Syncthing Preferences window API key text box it doesn’t restart when a new API key is used. This is almost the same bug.

But @Tango have you tried the workaround instructions from my answer in issue #210 ApiKey defaults not in sync with config.xml, autodetect and notify user · Issue #210 · syncthing/syncthing-macos · GitHub.

The icons are small because the bar is only around 16x16 pixels. There are 4 notification icons: Idle, Notify (exclamation mark), Pause, Syncing. See https://github.com/syncthing/syncthing-macos/tree/develop/syncthing/Assets.xcassets.

The notification mark can look like an 1. The best thing would be to use the native macOS notification service. I did create a prototype. But I don’t want to be the application to naggy, so it has not been integrated. I tried to catch the Share notification.

Hope this helps.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.