Lost config after installing uninstalling Syncthing macOS


I have just noticed that my config has been wiped two days ago. Now, it’s not too much of a problem for me since I can reconfigure everything, I’m trying to understand what happened and how I can prevent next time.

Here is what I have so far:

  1. I have installed Syncthing via Homebrew a long time ago.
  2. 3 days ago, I read about Syncthing macOS and decided to give it a try.
    a. I installed it, started it, I was expecting it to have its own config but somehow it grabbed the existing config and everything seemed fine.
    b. I saw that it was running its own executable (v0.14.52, I believe), I stopped it and started the one from Homebrew. Syncthing macOS had the API key etc configured so it started using the API and everything still seemed fine.
  3. At some point in the last two days, I decided that I didn’t really need Syncthing macOS so I deleted it.
  4. Today, I tried to open the web UI, it didn’t open. I thought the service wasn’t running so I tried to start it, it said it was running so I restarted it. Still no luck accessing the web UI.
  5. I checked the logs and saw that it was running on port 8384, while I had it configured to run on port 8080.
  6. I opened the web UI on port 8384, everything was gone.
  7. I checked the logs again and I saw nothing useful. It’s only telling me that the config and the certificate was gone and it regenerated.

Here are the relevant parts of the logs:

[GNVF5] 22:47:52 INFO: Disconnected from relay relay://
[GNVF5] 22:47:52 INFO: Relay listener (dynamic+https://relays.syncthing.net/endpoint) shutting down
[GNVF5] 22:47:52 INFO: Exiting
[start] 23:43:57 INFO: Generating ECDSA key and certificate for syncthing...
[FREPI] 23:43:57 INFO: syncthing v0.14.50 "Dysprosium Dragonfly" (go1.11 darwin-amd64) ComputerName@LanName.lan 2018-09-02 19:36:07 UTC [noupgrade]
[FREPI] 23:43:57 INFO: My ID: FREPIXO-[...]
[FREPI] 23:43:58 INFO: Single thread SHA256 performance is 111 MB/s using crypto/sha256 (97 MB/s using minio/sha256-simd).
[FREPI] 23:43:58 INFO: Default folder created and/or linked to new config
[FREPI] 23:43:58 INFO: Deft config saved. Edit /Users/UserName/Library/Application Support/Syncthing/config.xml to taste or use the GUI

Any ideas what might have gone wrong and at which step?

Both of them were using the same config, so uninstalling one probably uninstalls the config used by both.

The Syncthing macOS bundle tray application doesn’t touch any files in the Library/Application Support/Syncthing folder. I tried to figure out if the homebrew syncthing cli installation removes this files but only could find this: https://github.com/Homebrew/homebrew-core/blob/master/Formula/syncthing.rb

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.