linux auto start & receive only setup

Just install ST and liking it a lot. I have a couple of questions hoping someone can help me with.

I have two servers at the moment main and backup. I want files from main to be sentto backup but any changes on backup ignored i.e if i created a file on backup i don’t wanted it send to main.

On main I have folder type set to to send only On backup there doesn’t seem to be an option for receive only?

I’m running debian 8 and would like to have synthing start on boot but on main eth0 address i’ve followed this guide do I really need to install Nginx to make it available via the wan or is there another way?

I tried changing the interface from lo to eth0 in /etc/init/syncthing.conf but that didn’t work.

Description “Syncthing P2P sync service”

start on (local-filesystems and net-device-up IFACE!=eth0) stop on runlevel [!2345]

env STNORESTART=yes env HOME=/home/synct setgid “synct”

exec /usr/local/bin/syncthing


To have the WebUI available from outside, you need to set the web UI listening address in the syncthing config (/home/synct/config.xml) to .

Receive only is coming soon. For now setting the main to send only will suffice. If there are sxhnages on the other one, it will send it to main but main will reject them and give you the option to reset them (“override changes”).

Thanks for the reply, forgot to mention I previously change it to in config.xml and it works as expected when running syncthing via the command line but not as a service.

Try start on (local-filesystems and net-device-up IFACE!=lo) OR start on (local-filesystems and net-device-up IFACE=eth0)

(The “!” means “not”)

But if you are using Debian 8, I would recommend using systemd for this.

If you use the apt packages - you just need to enable the systemd service since it is already included:

You also don’t need Nginx for the webinterface to work - this is optional.

I tried

start on (local-filesystems and net-device-up IFACE!=lo)

but no change, systemctl status showed

Access the GUI via the following URL:

not sure why the port has changed?

I would like to run as a system service

There is already this file /lib/systemd/system/syncthing@.service

linux-systemd doesn’t exist?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.