Issues to sync : same network and outside - relaying and upnp

Hello,

Sorry for the trashy title I really don’t know how to phrase that one.

So basically my setup is the following and the laptop has issues syncing with the rest.

  • laptop - manjaro - v0.13.4 (local) ← the problematic one
  • NAS - synology - v0.13.5 (local)
  • vps - ubuntu 14.04 - v0.13.5 (external)

All of those run the latest version in the repro but only my laptop has connexion issues.

First it uses a relay to connect to the vps, which is slow and doesn’t make any sense given the fixed ip and the open ports.

On the local network, the NAS is downloading from the server instead of the laptop.

The vps has a fixed ip. I have this log on the laptop, although the address (ip:22000) works just fine to sync btween the vps and the NAS.

[JJUTV] 13:33:11 INFO: Dialer for XXX.XXX.XXX.XXX:22000: unknown address scheme ""

I don’t have the option for upnp but for the laptop only to ‘Enable NAT traversal’ (I guess it is the same) and if I disable relaying no connexion is setup anymore.

Any help will be appreciated, and sorry again for the fussy way I’m trying to explain my issue.

Unknown address scheme implies that one of the addresses you configured manually is incorrect. I am not sure I understand the overall issue as they are blended in with generic statements.

Best would be to describe like this:

What did you try to do: I tried to do X

What happened: Y happened

What did you expect to happen: Z was supposed to happen.

If you specify the ip manually, you need to prepend the scheme, so tcp://ip:22000. Without that, you NAS should get the same error.

@wweich the tcp://ip:port did the trick. I guess that something that was implemented in the latest release as I’ve been using only ip:port in the address field since awhile now.

@AudriusButkevicius will keep that in mind for next posts.

  • tried to sync A (laptop) with B(server) and C(nas)
  • sync used a relay between A and B + no sync between A and C
  • fixed using the right synthax

Thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.