Inaccurate sync percentage + Strange conflicts created with music files #1277

#1

I’m fairly new to creating bug/issue reports, so let me know if I need to do anything differently.

I set my Music folder as “Send & Receive” on my laptop and desktop, and receive only on the microSD card on my Android phone like:

/storage/014A-7323/Android/data/com.nutomic.syncthingandroid/files/Music

When I change a file, for example of I were to take “meow.mp3” and change the artist from “My Cat” to “Your Cat” via tag, the new file is uploaded but the old was is named “.sync-conflict-XYZ”

It doesn’t seem to happen all the time, but becomes especially apparent when all the files from a folder are removed, here’s a snippet from an old log file:

INFO: Puller (folder "Music" (*****-*****), file "Kevin Rose/The Kevin Rose Show"): delete dir: directory is not empty

I tried adding this to the ignore file with no change: (?d)*sync-conflict*

I have tried rebuilding my database, resetting the delta indexes, and removing all Syncthing related files and doing a complete rescan, but nothing seems to change it.

My youtube-dl files in a directory next to it on my SD card seem to sync fine, but I do remember having a similar issue with it that I cannot reproduce.

Also, my desktop seems to report a seemingly random sync percentage for the device, despite the files being synced over:

My Android just goes between “Scanning” and “Out of Sync”

Not sure if that has anything to do with it.

I posted this on the Github page originally thinking it was a bug (I really thought it was :persevere: ), but was told to post it here

Please let me know if there’s anything I can do to assist with this, Syncthing has simplified my life a lot and I’d love to help if I can.

### Version Information

    App Version: 1.0.1 (currently using Syncthing-Fork by catfriend, but this issue stands with the original Android version on F-Droid.
    Syncthing Version: v8.0.0
    Android Version: Android 8.0.0 (tested on Samsung Galax S5 and LG G6
(Catfriend1) #2

I don’t think the issue is specific to the fork. I’ve had that behaviour before on a test device with low memory but that might not apply to your case. Would be worth to check if your memory is filled up. To save resources, you could also try to enable largeblocks on both sides.

(Simon) #3

If you can’t fine give steps to reliably reproduce this, more logs would be a starting point. it’s impossible to say anything specific from that single line alone. I think directory not empty can also be a symptom of non-matching ignore patterns.

(Catfriend1) #4

@imsodin btw would it help if I make the download support bundle available on the wrapper UI?

(Simon) #5

Completely forgot that existed. I’d first have to check what it contains - can’t think of anything but logs that would be relevant in this case.

(Catfriend1) #6

Uhh yes, maybe a share button is more secure than downloading the support bundle to sdcard where every app has access to it.

(Simon) #7

So yeah I guess it would be nice to have, as it makes sharing the config (which is hidden/protected) on android simpler, but I don’t consider it important. Logs are important, the rest is rarely needed and can be asked for “on-demand”.

1 Like
#8

First of all, I thank the both of you for your contributions to this extremely useful project.

Here is an part of an old logfile, I’m sorry I don’t have any other useful info besides this:

--------- beginning of main
--------- beginning of system
02-13 20:16:00.917 I/SyncthingNativeCode(17605): [*****] INFO: Puller (folder "Music" (*****-*****), file "藤舎推峰/静寂~古都の瞑想"): delete dir: directory is not empty
02-13 20:16:00.949 I/SyncthingNativeCode(17605): [*****] INFO: Puller (folder "Music" (*****-*****), file "藤舎推峰"): delete dir: directory is not empty
02-13 20:16:00.982 I/SyncthingNativeCode(17605): [*****] INFO: Puller (folder "Music" (*****-*****), file "Kevin Rose/The Kevin Rose Show"): delete dir: directory is not empty
02-13 20:16:01.554 I/SyncthingNativeCode(17605): [*****] INFO: Folder "Music" (*****-*****) isn't making sync progress - retrying in 4m0s.

I tried to do find a fresh logfile but couldn’t find anything that had any new errors.

I let it try and sync overnight, it shows 15,878/15,878 synced at 99%, then either says out of sync or syncing. Log file is empty.

Desktop says that its 92% synced: error0

And seems to list seemingly random files (not just Japanese music, so its not a character error):

Actually, just checked the Android logfile, it says: Puller (folder "Music" (****-*****, file "xyz"): delete dir: directory contains unexpected files, scheduling scan over and over again

I’m rushing to school right now, but I have another sync going on my school laptop that should be done later that I can compare to to see if its truly an Android only issue. Sorry if this is a big disorganized. Please let me know what I can do next.

Edit: One of the device names says galaxy s5, it is a s7. Misnamed it, don’t know how relevant that is though

(Audrius Butkevicius) #9

Do you have ignores setup?

#10

Not currently, no. I tried using (?d)*sync-conflict* before though with no luck.

(Audrius Butkevicius) #11

I’d check what are the files left in that directory.

#12

Ok this keeps getting weirder. After testing it on my laptop, I’ve confirmed that its only on my Android. Everything syncs fine to there.

It was syncing all the files but says “Out of Sync 99%” error, and the log said it failed to delete a directory. I noticed that the directory had a “.” in it, which I removed that and now it says Idle in green, which means its syncing fine! Yay for progress!!

Desktop says:

Screenshot_2019-02-22_14-12-53

When I click the items it just literally lists all of the folders which are already synced:

Could my Android be doing something to the folders to make them different that wouldn’t change the actual files? I have the ignore fat permissions item checked.

(Audrius Butkevicius) #13

Do you have a screenshot from android for that folder?

My money is that android does not support the non-ascii characters you have in the filenames, yet it should complain about that loudly.

#14

I don’t think it is ): We’re back to square one, it says 67% synced and says various files/folders are not synced even though they’re on my phone.

Here’s a screenshot of some files with english characters:

(Audrius Butkevicius) #15

You keep looking on the wrong side. The errors will be on the phone, the fact that you know that it’s out of sync by looking from your desktop doesn’t help understand what the issue is.

#16

I will try and get a log next time it happens. Currently, on the phone it says 100% synced (just is green with idle) with an empty logfile, but on my desktop it shows the above.

Is there any way to make the logs more verbose?

(uok) #17

You can also check the Syncthing GUI in the phone app (there is a menu entry for that) for more info.

#18

Sorry for the delay in responding. With the help of Catfriend1 I’m getting the support bundle installed so I can properly post a log with more information.

1 Like
#19

Alright, here’s the update. Unfortunately I don’t think I can continue to debug this or use Syncthing for this folder.

I tried a full sync of my music folder last night with the Syncthing-Fork so I could try and debug it, and when I woke up my microSD card was unable to be read by anything, my computer won’t even detect it.

This happened to my last phone (LG G6) a few weeks ago, I didn’t include this earlier because I thought it was a fluke/unrelatd

I’m not sure if its a heat thing or a read/write thing with the large number of files on a microSD card, but I don’t I can afford any more microSD cards at this point (hopeully Amazon will let me return this one :confounded: )

Mods can close this thread, if anyone curious I would be more than willing to answer any questions about it.

Thank you everyone for your time try to helping me solve this! Hopefully I’m just getting bad sandisk sd cards.

(system) closed #20

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.