In "Actions" -> "Settings" -> "Connections", how to use a private, remote relay, but not allow local relaying for randos out in the cloud?

Hello, I would like to make sure I’m understanding how to use Syncthing 1.6.1 correctly.

An important factor here: I’m using syncthing from behind a cellular data connection, not a home DSL or cable internet connection. The cellular data connection handles multiple connections ungracefully. By far, it’s best to do just one thing at a time through this connection, for way better download speeds and reliability. Network service gets degraded quickly, for all users on the LAN, with every extra network connection that assumes it wouldn’t cause any harm, deciding on its own to also make use of the cellular data connection, unbidden.

I have a private Syncthing relay server set up on a hired VPS out in the cloud, and on my firewalled, local Syncthing clients I enter the “relay://…” address properly, as per here. I want that public VPS to do the relaying only, if necessary (no direct, firewall-punching Syncthing connections being possible) and I don’t want my local, firewalled clients acting as a relay for strange Syncthing instances out in the cloud. I seek assurance that this is not happening.

So what does it mean if I also uncheck the “Enable Relaying” Checkbox on that same page, on the locally firewalled Syncthing clients? Does it mean:

  1. Don’t allow this local, firewalled Syncthing to talk to my relay on the cloud VPS any longer, which I’ve specified above in the "Sync Protocol Listen Address” textbox.

  2. Don’t allow this local, firewalled Syncthing instance to act as a relay, to random strangers also using Syncthing out in the cloud.

Note: Naturally, I do want local, firewalled clients to continue talking to each other locally on the LAN, as they are not firewalled from each other (so that’s not a case of “relaying”).

A Syncthing instance is never a relay, only relays are relays. Unchecking “enable relaying” means don’t try to connect to other devices over relays. (Except, maybe, if you’ve actually hardcoded a relay address as described. I’m not sure if the checkbox applies then or not. you can try it.)

1 Like

Thanks for that assurance.

After trying it, it seems that unchecking the “Enable Relays” checkbox will dutifully override any usage of the private relay server specified in "Sync Protocol Listen Address”.

Furthermore, two remotely-separate Syncthing instances (both NAT’ted) won’t even be able to “Add” each other (“Add Remote Device” button), if they both have a Private Relay specified, then “Enable Relaying” is unchecked.

Weird edge case, I know…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.