how to upgrade manually ?


i’ve installed syncthing on Raspberry Pi 3 last year with the tar archive on Github. It was the 0.14.6 version. I want to upgrade the software but when i click on the button (in the GUI), i have an error : “upgrading: open /opt/syncthing/syncthing416423085: permission denied”. How can i upgrade manually with command line ? i don’t see anything on the documentation.

EDIT : I just see on the documentation the command line operation … My bad … I will try to upgrade this way.

If you upgrade with the command line option, you wil end up with the same error.

Syncthing doesn’t have the permission to create and rename files inside /opt/syncthing/.

You either have to correct the permissions, or upgrade manually (really manually), by downloading the current version and replacing the binary while syncthing isn’t running.

Thank for the answer !

i upgrade with this command:sudo syncthing -upgrade

I suppose that i will have the same error when syncthing automatically upgrade itself ?

I need to change the permission. I have to give permission to the user who launch syncthing ?

If you use self-upgrading and don’t run Syncthing with root privileges (good) I would place the executable to a place where the user has write access. The usual place is ~/bin and in some cases that’s already added to your PATH.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.