How to set the file mask

Syncthing is running in xigmanas, freebsd . The permissions of the files which has been synchronized is “rw-r-r” , owner is “syncthing”. Xigmanas is x64-embedded,the user “syncthing” is in a system group “syncthing”,so i can‘t change “syncthing”‘s umask. My nfs service is running as root, so i can 't write any file. So i want to know how to set the file mask.

i can’t find any option to chang the mask, help me , thx.

Either you

  • set the umask to what you like (how you do this is system dependent, but surely possible) and set “ignore permissions” on the folder, or
  • Syncthing will use the permissions the file had on the other side.

thx.i’ll try to change the umask.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.