How to install syncthing on aheadless cluster without admin privialages

Hi guys, first day of using Syncthing and my first post here. I had originally posted my question here on askubuntu but I was advised to come here.

I’m running lots of simulations on a headless cluster where I don’t have admin privileges. I want to use syncthing to sync them across multiple machines. I have successfully installed syncthing via LinuxBrew and now I have:

syncthing v0.14.50 “Dysprosium Dragonfly” (go1.11 linux-amd64) linuxbrew@ef99f5dbb144 2018-09-02 19:36:07 UTC [noupgrade]

I was trying to follow the instructions here till I realized I don’t have admin privileges to create a folder called init in the etc folder or create a new file there. I’m also not able to install upstart via linuxbrew. The formula does not exist. and compiling it from source also fails due to some dependencies… I would appreciate if you could help me know how should I do that.

I am not sure you can make syncthing autostart if you don’t have admin privileges, you should ask your VPS provider how can you make applications autostart. Other than that, syncthing should work and keep running until reboot if you launch it on the command line.

The cluster never reboots. That’s not a problem. The issue is I can’t access the webUI.

You have to ask your VPS provider to expose a port, or force syncthing to listen on some port that is exposed by the VPS provider.

ssh port forward of port 8384 to localhost should be fine. It’s in our docs, or any ssh guide.

asking VPS (I suppose they are the admins) is not an option. forcing to listen to a different might be possible. how can I do that?

sorry I’m very noob. How can I do that?

In the IRC channel /I’m being advice to use systemd. I have set up the file ~/.config/systemd/user/syncthing.service with this content. But no idea what should I do next.

there must be some sort of step by step instructions for such a situation where there are no admin privileges on a headless server. I would appreciate if anybody could give me a link.

@foadsf do the legwork, @calmh explained where docs with the explanation are. There are plenty of ssh forwarding guides on the internet too.

sure in the meantime I will go and read the documentations. at this moment I’m under pressure to get some stuff done. that’s why I’m asking for help here.

next step on these instructions I was asked to run the command systemctl --user daemon-reload && systemctl --user enable syncthing && systemctl --user start syncthing and I got Created symlink from /home/foobar/.config/systemd/user/ to /home/foobar/.config/systemd/user/syncthing.service.

tried ssh -L 8384: <server IP> for port forwarding but got ‘Permission denied’

try :

ssh -L 8384:localhost:8384 username@serverIP and this should ask you to provide the pwd for remote server. open the browser on the localhost and go to localhost:8384 to access the WEBUI

I tried and got the error:

bind: Cannot assign requested address

perhaps it is trying to bind an IPv6 address?

1 Like

Which means try with -4 option (which by the way is in both the first and second result of a duckduckgo search for “ssh cannot assign requested address” - lets hope it really fixes your problem).

1 Like

Thanks a lot the -4 works. what should I do next? I tried browsing the <IP>:8384 but it does not load the webUI.

when tried to run syncthing I get :

[monitor] 01:26:53 INFO: Starting syncthing

[JNJHE] 01:26:54 INFO: syncthing v0.14.50 “Dysprosium Dragonfly” (go1.11 linux-amd64) linuxbrew@ 2018-09-02 19:36:07 UTC [noupgrade]

[JNJHE] 01:26:54 INFO: My ID:

[JNJHE] 01:26:55 INFO: Single thread SHA256 performance is 338 MB/s using minio/sha256-simd (332 MB/s using crypto/sha256).

[JNJHE] 01:26:55 INFO: Hashing performance is 285.30 MB/s

[JNJHE] 01:26:55 INFO: Ready to synchronize “Default Folder” (default) (sendreceive)

[JNJHE] 01:26:55 INFO: Overall send rate is unlimited, receive rate is unlimited

[JNJHE] 01:26:55 INFO: Rate limits do not apply to LAN connections

[JNJHE] 01:26:55 INFO: Using discovery server

[JNJHE] 01:26:55 INFO: Using discovery server https ://

[JNJHE] 01:26:55 INFO: Using discovery server https ://

[JNJHE] 01:26:55 INFO: Relay listener (dynamic+ starting

[JNJHE] 01:26:55 INFO: TCP listener ([::]:22000) starting

[JNJHE] 01:26:55 INFO: Completed initial scan of sendreceive folder “Default Folder” (default)

[JNJHE] 01:26:55 INFO: is “foobar” at [dynamic]

[JNJHE] 01:26:55 FATAL: Starting API/GUI: listen tcp bind: address already in use

[monitor] 01:26:55 INFO: Syncthing exited: exit status 1

[monitor] 01:26:56 WARNING: 4 restarts in 11.46765575s; not retrying further

Most likely Syncthing is already running (you can check with ps aux | grep syncthing).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.