Help with syncthing not connecting when pluggin to mikrotik

hello i am having problem with my syncthing , from this day i been using syncthing plugged in to my Internet modem , then when i try to connect my pc to mikrotik syncthing appears disconnected from my target servers , please help me with my problem . so in order to use syncthing i need to plug my pc back to internet modem directly

disconnected

There is not enough information to really say anything. Please at least briefly describe the hardware, type of connection, and operating systems that are in use here. Is “mikrotik” the router? Have you disabled any connectivity-related options in Syncthing that were turned on by default? A full screenshot of the Web GUI will be welcome.

here is the screenshot i did not change some of my settings and just disable global discovery

mikrotik is the router i am using , operating system is windows 10

Please try to re-enable global discovery and also set the listen addresses to default, then see whether the devices can connect, and if yes, check what kind of connection/address is being used. If it’s not a direct connection but rather a relay, then you will likely need to check and modify your router and/or firewall settings, so that direct connections between different devices are allowed.

If the “PC” is Windows, then you will also need to set the network type in the OS to “private” instead of “public”, as otherwise Windows won’t allow direct connections either.

1 Like

i tried that all , did not blocked any ports regarding with mikrotik and also restore to defaults my mikrotik but still actions not passing

I’d say the problem is likely on the router’s side. Have you enabled client isolation or something in that vein in the router settings? Syncthing should still be able to connect via relays even then though.

i dunno , if you want to you can check my settings remotely , i still having problem and it wont went through