Hangs on Startup

Ok so I tried setting up Syncthing on my desktop and laptop (both running Xubuntu 14.10) and while it all worked well on the desktop, the laptop is having a bit of a problem.

When I start it for the first time it outputs

[QOR7Q] 22:05:24 INFO: Creating new HTTPS certificate [QOR7Q] 22:05:24 INFO: Generating RSA key and certificate for Apollo…

and there it hangs. The web interface launches and is responsive (I can add folders/devices, although it doesn’t see any connected devices - it doesn’t start the discovers services, so how should it), but if I change anything and try to restart, well it hangs…

The whole thing is a bit weird, since I don’t really see what would be the difference between the 2 platforms - with Syncthing being statically linked .

Thanks for any advice.

EDIT: I’m also using the same binary on both systems syncthing-linux-amd64-v0.10.20

Generating keys can take multiple minutes on a weak device. Just relax, and give it some time.

well it’s a Dell XPS 13 with a i7-4500, which is actually more powerful than the desktop, and I waited about 45 minutes before posting here.

Also there is new insight: the web interface seems to be the problem, when it opens automatically the program hangs and if I close the tab it continues running as it should.

EDIT: if I open the interface up manually after closing it, it continues to work fine

Strange, what does the log say? Can you run some debug by setting STTRACE=model env var?

so the log says:

[monitor] 2015/01/19 00:07:16.452072 monitor.go:104: INFO: Starting syncthing [WYS7E] 2015/01/19 00:07:17.072174 main.go:401: INFO: syncthing v0.10.20 (go1.4 linux-amd64 default) unknown-user@syncthing-builder 2015-01-13 16:27:47 UTC [WYS7E] 2015/01/19 00:07:17.072322 main.go:402: INFO: My ID: WYS7ET3-BDOETQG-ESXWJQH-C6CNITM-AF5WSG4-Q53MRLD-OSIDSYB-AS6B2QG [WYS7E] 2015/01/19 00:07:17.228688 progressemitter.go:99: DEBUG: progress emitter: updated interval 5s [WYS7E] 2015/01/19 00:07:17.228765 main.go:654: INFO: Starting web GUI on [WYS7E] 2015/01/19 00:07:17.229811 progressemitter.go:66: DEBUG: progress emitter: timer - looking after 0 [WYS7E] 2015/01/19 00:07:17.229840 progressemitter.go:82: DEBUG: progress emitter: nothing new

there it hangs, after I close the web interface it continues with

[WYS7E] 2015/01/19 00:07:49.194857 upnp.go:106: INFO: Starting UPnP discovery… [WYS7E] 2015/01/19 00:07:55.195991 upnp.go:133: INFO: UPnP discovery complete (found 0 devices). [WYS7E] 2015/01/19 00:07:55.196060 main.go:1134: INFO: Starting local discovery announcements [WYS7E] 2015/01/19 00:07:55.196261 main.go:1139: INFO: Starting global discovery announcements [WYS7E] 2015/01/19 00:07:55.197443 main.go:575: INFO: Device WYS7ET3-BDOETQG-ESXWJQH-C6CNITM-AF5WSG4-Q53MRLD-OSIDSYB-AS6B2QG is “Apollo” at [dynamic]

and again - additional insight:

it only hangs if it has to start the browser (Chrome) to bring up the web interface, if the browser is already running so that it only has to open a new tab, it works fine.

This is also the difference to the desktop - on there I’m using Firefox

Could the problem be low entropy?

It doesn’t look like it’s the full log though, as I don’t see a folder starting.

well actually I removed the default folder, so it doesn’t have any folders to start…

well no, as it turns out, it’s not only hanging on first start, but on every startup. Always when it opens the web interface

I’ll make a build later tonight which panics on a specific signal just to figure out where it gets stuck, if you are fine to debug this for me.

Can you try sending it a SIGABRT and see if it dumps cores and perhaps stack traces?

sure, here you go<a class=“attachment”

syncthing.log (6.1 KB)

There are two processes, one parent process (monitor process) and a child process which is actual syncthing. It seems you’ve killed the monitor process rather than the child, can you please do the same with the child?

like this?

another.log (18.3 KB)

Much better, thanks!

Thanks, this is now: