Global & Local State does not match

As the title states I am looking for some assistance. The screenshot below shows that the global and local states do not match on both sides.

There has been one fix related to local/global states and receive-only folders, that is in v1.9.0-rc.1. If you don’t want to update, you can see if running once with STRECHECKDBEVERY=1s (recalculates those numbers) gets rid of the issue. Unfortunately I don’t know any possible way to debug this after it happened. If you ever notice when/how the discrepancy happens, respectively can reproduce it, please let me know.

I can’t seem to get that to work in Windows. do I just have to go to the folder its installed via the command prompt and run “syncthing STRECHECKDBEVERY=1” ? I downloaed the base syncthing windows download on and have it running as a Windows service using nssm.

If you are running Syncthing as a system service, then I think that adding STRECHECKDBEVERY to the system variables with a value of 1s (not 1) should do the job. Remember to reboot Windows after doing so.

I added the system variable in Windows, restarted the syncthing service and it recalculated the global and local states on the windows box. Both of them match on the Windows box now. On the FREEBSD side i restarted syncthing like I normally do and it seems to have cleared things up there as well. Did I just need to restart syncthing on both boxes?

Instead of modifying all system services context under Windows, I’m just setting the STDB… var via nssm in the context for Syncthing. If the service is called “Syncthing” the following two helper scripts plus a service restart from Windows services control panel can do it quickly.

Btw is the var now “1s” instead of a previous advice of “0”?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.