Frustration with syncthing-GTK (an experience report with some solutions and some questions)

Hi,

I have installed Syncthing-GTK 0.12.8 32 bit on a PC with Win 10, 64 bit. (Why is there no 64 bit release?)

The output of syncthing-inotify is:

[WARNING] 21:44:44 Cannot connect to Syncthing: Get http://0.0.0.0:8080/rest/404: dial tcp 0.0.0.0:8080: ConnectEx tcp: Die angeforderte Adresse ist in diesem Kontext ung??ltig.

So I changed both, syncthing and syncthing-inotify to the latest release 0.12.10, 64 bit. The message remains the same; so I took back the release 0.12.8 and syncthing-inotify 32 bit. (Isn’t it allowed to switch to 64 bit releases?)

Inotify doesn’t work as expected. When I add a file to a “watched” folder, the changes aren’t recognized. When I restart syncthing-GTK, the number of files is shown correctly. So I changed the rescan interval to 0s. Afer a restart I see, that there now is an entry “deactivated”. Ahaa… now it works. The entry “activate local discovery” can be found in an other configuration-window. (Why doesn’t the system set the interval in this case automatically to “deactivated”? Where from should the normal user know about this dependency?)

Now I see:

[OK] 22:06:34 Watching Sync: H:\Syncthing\Sync
[OK] 22:06:34 Watching Lifetab: H:\Syncthing\Lifetab
[OK] 22:06:34 Watching ST_Austausch: H:\Syncthing\ST_Austausch
[OK] 22:06:34 Syncthing is indexing change in Sync: [.stfolder]
[OK] 22:06:34 Syncthing is indexing change in Lifetab: [.stfolder]
[OK] 22:06:34 Syncthing is indexing change in ST_Austausch: [.stfolder]
[OK] 22:07:32 Syncthing is indexing change in Lifetab: [oggdropXPd - Kopie - Kopie - Kopie - Kopie - Kopie - Kopie.exe]

That’s ok. (The first error message seems to be a little bit useless to locate the problem.)

The checkbox for “activate sending of anonymous userdata” doesn’t stay selected. After a restart, the checkbox is unchecked again. Why? (In the local website of syncthing, the button is unchecked, but stays checked/unchecked when changed.)

I cannot access to the local html site of syncthing. The login panel appears, but I cannot authentificate myself, even not with the login-information given in the config.xml. What can I do to access this local website? I deleted manually the user and password from the config.xml and got - access. The changed user now is written in the config.xml as plain text, the password is encrypted. (Before, it was also plain text.)

BTW: At some time Syncthing-GTK loads the old 0.12.8 instead of the actual 0.12.10. Why is there a checkbox to automatically load the last release?

When I change the local website from http to https, syncthing-GTK crashes and cannot be restared. A panel “… Failed to load daemon certificate” occures. So I watched the config and changed tls from true to false. (Wouldn’t it be better, if the last working config.xml would be safed?)

The Info-Button has a link to GitHub. Oh, there could be help … no there is no link. A panel appears.

Something went wrong … I suggest to make the application more user-friendly in the shown cases, because the average user will not solve all of these problems by himself.

Last but not least: I need a help button with some documentation :wink:

Greetings,

merlinuwe

Try SyncTrayzor: https://github.com/canton7/SyncTrayzor

This is a fully packaged Windows Version of Syncthing. Works like a charm (but i havent tried win10 yet)

It’s fine with win10 :smile:

Syncthing is probably still starting up (i.e. generating certs or scanning folders). Ref: Enable GUI before initializing folders by Zillode · Pull Request #2515 · syncthing/syncthing · GitHub

“activate local discovery”

This is part of different functionality, namely to discover other Syncthing clients in your network. Ref: http://docs.syncthing.net/specs/localdisco-v3.html

Sounds like a bug, open an issue on Github please.

Search for related open bugs on https://github.com/syncthing/syncthing-gtk and create one if there aren’t any.

Thanks for your feedback, it’s appreciated. I think a help button for Syncthing-GTK would be helpful and probably requires a helping hand to make it happen :wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.