Folder Marker missing - on one device, works on another

I know there have been many posts on the topic but I get this quite frequently syncing from a Win11 PC to Android - and I do not believe I deleted .stfolder. I have tried just creating a .stfolder folder and it makes no difference. And actually the failure is on new Google Pixel8a phone running Android 14. On an old Lenovo tablet running Android 12 it works perfectly. Deleting the folder pair and recreating it seems to make no difference.

If it doesn’t happen consistently or is reproducible, it’s going to be more difficult to debug, but odds are that something on your Pixel phone other than Syncthing is removing the .stfolder directory.

To test if it’s a cleaner app removing empty directories, put a file in .stfolder to make it look like it’s being used.

Strange but that seemed to work.

So I have 8 folders on my PC - all with a .stfolder. When I sync to my tablet it all works. With my phone all work apart from one - and consistently the same one. Deleting the folder pair and the phone folder did not work. Add in the phone folder did not work. Adding the phone folder with an empty .stfolder did not work. But putting a file in the folder and it worked. Hopefully I will have no more issues…

THanks for your help

Is the affected folder managed by a specific Android app – i.e. is it basically a data folder for an app, or is it just a random personal folder?

I guess just a random personal folder - I have a folder called Documents and the 8 folders I am synchronising are all sub-folders under that.

That’s definitely odd with it being the only one affected out of several subfolders.

Android itself has plenty of empty folders, so it seems very unlikely that it’s responsible for removing one of your .stfolder folders. Odds are there’s a 3rd-party app that’s cleaning up that particular folder.

If the collection of files in that folder aren’t random – e.g. all MP3s – whatever app(s) you use to access those files are the most likely candidates.

No - basically all PDFs in this and the folders that work.