Folder half out of sync while it shouldn't be, nothing transfered but high CPU usage.


(Wcubed) #1

Not sure how to concisely describe this one. I have a relatively large folder (600GiB) synced between my desktop and laptop. Before starting Syncthing I transfered the entire folder from the laptop to the desktop, so they should be almost the same (I did some work on the desktop, and then some on the laptop).

Now that the scan has finished the desktop side indeed showed a few files out of sync, a few kilobytes so nothing major.

The laptop side however shows a whole 375 GiB out of sync, which shouldn’t be the case.

The desktop sometimes spikes to 27% CPU usage, but only a few bytes get transferred. which might be a separate issue on it’s own similar to: Lots of files: high cpu load, slow transfer rate

I have tried restarting Syncthing on both ends and let it rescan the folder, but it still shows it’s out of sync. Could this have something to do with file permissions or modification dates? Or are those not synced by Syncthing.


(Simon) #2

After scanning both devices also need to exchange and compare their respective lists of files including permissions, modification times and block hashes. As everything was created at the same time, these have all to be checked for conflicts. If they are the same, no conflict copy will be created, but it will still take some time to realize that.

Guess (!) about the laptop out of sync items: It might simply be slower than the desktop and still assume, that it needs all the files in the index from the desktop. Given time, it will figure out that they are equal and this list of files will vanish without all/any of them being synced. You can check whether anything is actually synced by looking at the “Latest Change” in the folder or by opening “Global Changes”/“Recent Changes”.

We had a discussion about the most efficient initial setup of lots of data, but I can’t find it anymore. I would assume that it was faster, if you first scanned only one device, then share the folder with the second device. Thus the second device will already have the index from the first device in place and can check for modifications while scanning.


(Wcubed) #3

Thanks for the quick reply!

It looks like your guess could be right. The “Latest Change” is on both ends one of the files that I know has changed, and hasn’t budged in a while.

Will the “Syncing” percentage reflect how far the laptop is in realizing everything is fine, or will it stay where it is and suddenly go to 100% when it is finished?

One last question: I understand from your answer that Syncthing does sync permissions etc? Because then I might have to go in and fix some :slight_smile:


#4

It should rise while it’s processing the files. But afaik only per file, so one really big file will cause a huge jump.

It syncs permission, but not ownership, so there should be nothing to fix. The owner will always be the user running syncthing.


(Wcubed) #5

I indeed moved its percentage up just now, so I guess all there is to do is wait :slight_smile:

Thanks for the help. I don’t know how this works here, but do I need to indicate somewhere that the problem is solved?


(Simon) #6

If you don’t care about permissions being synced, there is an option when editing the folder to ignore them.

I don’t think there is any “solved” status for forum threads.


(system) #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.