First Sync / Existing big directory on both sides

I have on two nodes a directory with about >100GB (delta ~1GB). Syncthing is setup on both nodes. Every node is listed by each other.

I want to sync the mentioned directory but don’t want that all the data gets deleted just to sync the first time.

I’m asking because a test with a smaller directory results in a deletion while adding/activating the local directory to get sync to the remote node. The remote node shows the ui to accept the request and at the same time the local directory (remote side) gets deleted.

The preparation was to add on both sides the directory/folder with the same folder id but without the link to a node. After the indexing activity finished, the folder gets configured to be shared …

So, is such scenario approved. How the path looks like? Thanks!

PS: If its important: local node was configured as send-only, and remote node as receive-only

This should not happen I think, but what you’ve proposed should work, but you should still make a backup.

hey i’m facing the same problem. Hope anyone here can help me too. Thanks in advance. Regards,

Two reports of the same seemed worrying enough to try and reproduce, but I couldn’t with the following steps:

  1. Create 10 files with random data and copy them to the remote.
  2. Create folders with equal ID on local (send-only) and remote (receive-only), do not share. Intermediate result: 10 files each, revert button visible on remote.
  3. Share and accept folder: Everything stays the same.
  4. Rescan on receive-only: Revert disappears.

I tried to reproduce the mentioned test case (with 0.14.51 now) and was not able to get the same result (first test was with 0.14.50). I dare tried then to sync the mentioned folder with 100GB remotely and everything went well. The remote directory got not deleted. So, I tried more production directories the same way (same ID etc.) and it went also fine. Unfortunately the case is not reproducible. Thats good so far.

I noticed that configuring the folder the first time directly as “Receive Only” the “Revert button” appears and using this button before sharing the folder with the remote node will delete the whole content of the configured directory. Not quite the same but also a behaviour that is at first not expected.

Not sure if this is relevant for both cases (i didn’t check all variants). I noticed while configuring a folders the first time a “/” remains at the end of the folder path (showed in the overview). If it gets edited again (saved) the “slash” disappears … just for the sake of completeness of observed behaviour …

That’s expected from the way it is implemented (everything appeared on a device, that should not introduce changes -> revert all unless another device has the same items). However I agree that’s a pretty big gun handed over to the user to shoot himself in the foot.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.