Failing to load include file : how to correct path ?


#1

Adding a new folder, I add my #include .ignorepatterrns directive into the folder options. Sadly, I make a typo, and syncthing can’t load the ignore file, I see a notification in the GUI, want to correct the line but can’t edit the ignore patterns options from the folder, it’s greyed out. So I must remove folder and re-add it with correct #include directive. Is it the way it’s meant to work ? Even pausing the folder doesn’t work, ignore patterns stay greyed out.


(Catfriend1) #2

Related: Stop folder when loading ignores fails Behaviour will change in the next version according to PR: https://github.com/syncthing/syncthing/pull/5418 Maybe a dev can check if this is a new issue or already fixed by the mentioned PR, please?


(Simon) #3

You can manually edit the .stignore file located in your folder root.

It’s not fixed or more precisely it’s not related: A failure to parse the patterns means the file content isn’t stored and passed to the web UI, so there is nothing to edit there. Anyways this seems like a legitimate enhancement, definitely worthy of being tracked on github - please open an issue there.

As to how to fixing it: We could add an optional type parameter to /rest/db/ignores which can be ignore or expanded (like the current return fields) to restrict to outputting just that, meaning no error if parsing fails for type == "ignore". Or have separate endpoints for pattern input (user facing) and parsed patterns (globbing).


#4

Filed at #5425