Error 0.10.14: Automatic upgrade: couldn't fetch release information


after starting 0.10.14 I expected, that the automatic update to 0.10.15 started. But instead, I got this messages at the bottom of the website:

17:17:13: Automatic upgrade: couldn't fetch release information


17:32:31: upgrading: no such file or directory

I tried to update manually by clicking on the blue update button, but it needs one syncthing restart to get the update.

Seen on Win 8.1 32 bit, Win7 64 bit, FreeBSD 64 bit.

Hope, this feedback helps.



Confirmed (warning and also need to manual restart Syncthing for update) - copied to issue #1175

Thanks for building new releases so immediately. For me (only) in Windows 7 64 bit it was necessary to delete some syncthingxxxxxxxxx files (x are numbers) in c:\Programme\syncthing. After that, a click on the blue button installed the new release 0.10.17. (Perhaps it makes sense to delete these files by syncthing in later releases?)



Devs fixed this with release 0.10.17 - Thanks!

Yes, unfortunately .14 won’t automatically upgrade. Or rather, it does upgrade but not restart into the upgraded version and hence probably doesn’t clean up the temporary files either. Once there is a restart for whatever reason, the newly upgraded version will take effect.

Restarting Syncthing did not work, it seems that @merlinuwe is right: you need to delete these files manually.

Restarting syncthing worked for me on Windows atleast.


I’m facing this issue. I have two computers windows and linux. I followed @AudriusButkevicius’s advice. It worked on windows after restarting manually but didn’t work on linux. Any help on this?

I cannot reproduce it on Linux, and a simple restart works as expected:

root@d3:~/go/src/ ./bin/syncthing 
[monitor] 12:29:34 INFO: Starting syncthing
[RF545] 12:29:35 INFO: syncthing v0.10.14 (go1.3.1 linux-amd64 default) 2014-12-29 08:42:17 UTC
[RF545] 12:29:35 INFO: Starting web GUI on
[RF545] 12:29:36 OK: Ready to synchronize default (read-write)
[RF545] 12:29:36 INFO: Completed initial scan (rw) of folder default
[RF545] 12:29:36 INFO: Automatic upgrade (current "v0.10.14" < latest "v0.10.17")
[RF545] 12:29:39 WARNING: Automatic upgrade: couldn't fetch release information
[RF545] 12:29:47 INFO: Restarting
[RF545] 12:29:47 OK: Exiting
[monitor] 12:29:47 INFO: Syncthing exited: exit status 3
[monitor] 12:29:48 INFO: Starting syncthing
[RF545] 12:29:48 INFO: syncthing v0.10.17 (go1.4 linux-amd64 default) unknown-user@syncthing-builder 2015-01-04 19:18:14 UTC

You can always download the release by hand.

A second restart worked. Thanks. Resolved.

On Win 7 64 bit I had to delete the syncthingxxxxxxxxx files again while updating to 0.10.18. (The first automatic update failed, as I could see at the filetime of the first of the syncthingxxxxxxxxx files.) There were again a few (2?) restarts necessary to get rid of the blue update-button. (I saw no error messages.) It seems to me, that the issue isn’t completely resolved.

But the update on Win 8.1 32 bit was no problem.