Discosrv FreeBSD

I tried to let discosrv (discosrv-freebsd-amd64.tar.gz) run on my FreeNAS 64bit system, but it hangs: sometimes I get no respond from the shell, sometimes I get:

freenas# /mnt/NAS1GB/syncthing/discosrv -db-dir="/mnt/NAS1GB/syncthing/discosrv-db" &
[1] 3513
freenas# 2015/05/21 19:09:51 open /var/discosrv/stats: no such file or directory

And very rarely I get a normal response.

Rebooting does not solve the problem.

I tried to call:



/mnt/NAS1GB/syncthing/discosrv -db-dir="/mnt/NAS1GB/syncthing/discosrv-db"

I downloaded it from here (#1077): http://build.syncthing.net/job/discosrv/

(Some newer downloads have a red marble.)

The content of the file /mnt/NAS1GB/syncthing/discosrv-db/LOG:

=============== May 21, 2015 (CEST) ===============
19:11:28.016891 log@legend F·NumFile S·FileSize N·Entry C·BadEntry B·BadBlock Ke·KeyError D·DroppedEntry L·Level Q·SeqNum T·TimeElapsed
19:11:28.017603 db@open opening
19:11:28.020986 db@janitor F·2 G·0
19:11:28.021052 db@open done T·3.421664ms

Any idea?



mkdir -p /var/discosrv/stats

is the any output to stdout?

It is not possible to build this directory, because it is a FreeNAS system which boots from usb-stick and the system is write protected.

The only output is

freenas# 2015/05/21 19:09:51 open /var/discosrv/stats: no such file or directory



2015/05/21 19:33:06 open /var/discosrv/stats: no such file or directory

… but I have called the following line, so this “cannot be”:

/mnt/NAS1GB/syncthing/discosrv -db-dir="/mnt/NAS1GB/syncthing/discosrv-db" &

The stats file is a separate flag:

discosrv -db-dir /tmp/foo -stats-file /tmp/foo-stats

No output is normal; you’ll only get output in case of errors, and in the stats file every five minutes or so.

I tried the following:

/mnt/NAS1GB/syncthing/discosrv -db-dir="/mnt/NAS1GB/syncthing/discosrv-db"  -stats-file /mnt/NAS1GB/syncthing/foo-stats

After 10-15 minutes, there occures this output in the file “foo-stats”:

1432234800 Kept:2 Deleted:0 Took:0.0257s

Does this help to localize the issue?

That looks like it’s working perfectly. Two announces are in the database. What’s the actual problem?