Devices frequently can't communicate

Syncthing version: syncthing unknown-dev “Erbium Earthworm” (go1.13.5 linux-amd64)

OS: Ubuntu 20.04 LTS / Android 10 (Graphene OS) on Pixel 2 XL

I’ve hooked up Syncthing between my phone and PC. It works fine sometimes, but most of the time each device says the other is disconnected when it’s not. They both have an internet connection that works.

Both devices are also connected via a VPN, which I figured may be interfering with the local discovery network. So I tried using a public relay server instead ( ). This didn’t work either, each device still thinks the other is disconnected.

I’ve tried restarting the daemon on each device and manually triggering a sync. I’ve also tried reconnecting the internet on each device. Sometimes messing around with this gets it to work and it syncs properly. But 90% of the time it doesn’t and is extremely unreliable.

I’m not sure what I’m doing wrong, as as user I expected this work pretty seamlessly.

Advice unspecific to your actual problem (though it might also solve it):

That’s not an official build, it doesn’t even have any version and according to the go version looks quite old. I suggest you upgrade your Syncthing (possibly through

I installed with apt, so it must be official?

At least someone has put it in some repository that you use, yes, apparently. But it’s not, and I’d be very sad and disappointed if Ubuntu or Debian shipped stuff in the above state.

So disappointment it is. Apparently this is precisely what Ubuntu is doing. I downloaded the latest 1.1.4~ds.1 from and it identifies as syncthing unknown-dev "Erbium Earthworm" (go1.12.9 linux-amd64) unknown@unknown 1970-01-01 00:00:00 UTC. Presumably you’re running something slightly newer since it’s compiled with a less ancient version of Go, but who knows.

I filed a bug. As is I can’t recommend running whatever it is they’re shipping.


Just did some more troubleshooting. It seems to work fine over WiFi, but not when I use Ethernet on my phone (even if the internet works on Ethernet). I checked the settings and I suspect it may because there is no configuration option to run when Ethernet is used—unless I misunderstood the options?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.