defining a sync folder on a "receiving" pc gives a permission error

Here is the situation:

  • source : windows 8 PC, syncthing, folder to be synced = \\NAS01\Public
    (the NAS is a QNAP)
  • destination : windows 8 PC, syncthing, location where I want to sync that folder to = \\NAS02\RMBU\Public
    (the NAS is a WD My Book Live)

On the destination:

  • I run syncthing at the commandprompt, with the logged-on user
  • that logged-on user has permissions to write to \\NAS02\RMBU\Public\
  • with the logged-on user I can create folders and files without issues

but I still get the error below: [3VJUT] 16:06:30 INFO: Skipping folder TEST01 scan due to folder error: open \\NAS02\RMBU\Public\.stfolder: The media is write protected.

so, what am I missing, or how can I solve this?


Looks like a trailing slash error to me. try adding a \ behind \NAS02\RMBU\Public

I am a little surprised to see this happening though.

Did you realy add \NAS02\RMBU\Public as the folder to be shared? Windows paths normally have to have a drive letter or \\ (UNC paths) at the beginning.

I see that the editor does some parsing of the \ . So I corrected my post to have it show the correct mount of \

which means, yes my paths start with \
and I do have a trailing \

So we had someone report this, but I couldn’t reproduce it. Double check that the path in config.xml ends with a slash.

Sorry for being slightly off topic, but may I ask why don’t you run syncthing directly off your two NAS boxes? That way you don’t need two PCs… I’m just curious :wink:

Depending on the size of the NAS Syncthing can be a heavy load for it. Some architectures are not supported. Getting it running on a soho NAS in general seems to be a lot of work judging by the number of requests for help.


I can understand your question, but here are the reasons

I have a few of those WD Mybook live drives (basically, external 2TB harddisks, connected to the network, with a tiny NAS OS) because I now have a big NAS at home, I don’t use them as primary NAS/Storage anymore. But in stead of getting rid of them, I moved them to an offsite location, with a small small switch and mini Win8 PC, so I can use it as "offsite backup" I don’t think the NAS OS can run Syncthing, and it would mean I’ve to hack 5 NAS, setup and maintain 5 syncthing instances by using a PC, I can centralize it

And yes, if it was only about syncthing, I could setup a linux pc, but because that PC does a few different tasks, some of them requiring Win8, I can’t setup linux

1 Like


so I think I found the issue, it has to do with the sandboxing of syncthing.

I will give a full explanation, which hopefully helps others

When I was looking for the logfile and config file, I didn’t find it where it was supposed to be: C:\Users\xxxxx\AppData\Local\Syncthing\syncthing.log the folder syncthing didn’t even exist. But I didn’t see errors trying to open the logfile, and because it had to keep the config file somewhere (it remembered the config after restarting syncthing) I searched the whole harddrive for the logfile and config file and I found it in C:\VTRoot\HarddiskVolume2\Users\xxxxx\AppData\Local\Syncthing

What is happening here : I’m using Comodo firewall (free version), which had an autosandbox feature. because it sees syncthing as suspicious software, it automatically runs it in a sandbox. (if you find a VTRoot folder on your harddisk, that is an indication you are using some kind of sandbox security feature)

Apps running in a sandbox, have significant limited rights, in this case also no access to network shares (even public ones)

After I turned off the autosandbox, copied the syncthing folder from the VTRoot to its normal location, and restarted syncthing, no more complaint about permissions it started scanning, and syncing from the “master”

Now I can start my evaluation of syncthing :slight_smile:

1 Like

Pesky firewalls…

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.