Custom upgrade server

Hello,

I’m actually syncthing own upgrade server My platform is buil of 3 old windows xp (386) with syncthing v0.14.4 The discovr server is for the instant on one of those xp

the upgrade server is based on w2k3 with iis 6

meta.json is well working, it’s announce me the new version 0.14.6 is avalaible. But download does not complete

[O4WRJ] 13:56:17 INFO: Automatic upgrade (current “v0.14.4” < latest “v0.14.6”) [O4WRJ] 13:56:17 WARNING: Automatic upgrade: zip: not a valid zip file

If I try to download zipfile in chrome, I’ve no problem to open zipfile.

Any Idea ?

Since I haven’t heard this from anyone else I expect the zip archive on Github to be valid. Have you double checked that you downloaded it correctly?

Yes I redo the download of 0.14.6 on syncthing repository. I also try to replace on IIS the zip file,by the 0.14.5.zip and rename it in 0.14.6.zip. Same thing each time

And no problem to download and open zipfile in a classic browser.

Then I don’t know. Given that it’s custom for you, it’s hard to debug. Maybe run with STTRACE=upgrade and see if that gives you anything useful.

I’ve tried it but no more in the output

For information, I try a lot of things :

  • take amd64
  • adds self-signed certificate for https to web server
  • convert from zip to tar.gz
  • analyze with procmon
  • start with -upgrade-to
  • each time I’ve got "not a valid zip file" So for now I don’t have any more idea to try

Have you tried loading the URL in question manually, to see that your webserver actually returns the zip file and not an error page or something?

Yes I tried and I haven’t got any problem do download and open the zip. No problem also to open the access json of course (all file mentionned in json are displayed in the cmd’s console and the corresponding os is well asked by syncthing upgrade.)

I’ve finally solved the problem,

IIS MIME Type for zip file is in "application/x-zip-compressed" syncthing need “application/octet-stream” so I juste made specific configuration in this way.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.