Custom discovery not working with 0.13


I upgraded my clients and the custom disco server to 0.13 flavor. And none of my clients see eachother ;(

My custom discovery server(v0.12) had worked perfectly with the clients. All I did was to upgrade the disco binary and I am using the same keys. And I can confirm that the server id is the same. So then I went ahead and upgraded the clients. I made sure that the dicscovery server url is same, ponting to the proper server url-id combo. None of the clients are using relays.

The clients and the server worked perfectly with the 0.12 in the current network setup. However 0.13 is failing badly for me here.

I reread the custom disco help page and made sure that I backtraced my steps. It was all good.

I also tried disabling nat traversal on the clients with no success. At the moment all the clients are behind the same router and the router has upnp.

Yes the clients and the servers are all 0.13x


When I click on “Discovery” in the clients web page, it says “nothing to announce”

I am using this format below in the clients

here is a portion of the log with sttrace=discover

DEBUG: globalClient.Lookup https://xx.xx.xx.xx:xxx/?device=xxxxxx-xxxx-xxx-xxx-xxxxx-xxxx-xxx-xxx 404 Not Found

So it cant find the discovery server, but why on earth?

The discovery server works, I am logged into it, the ip the port etc is correct. The ports are open properly in the firewall. Remember this exact setup used to work with 0.12 perfectly (minus the new binaries).

The only error I see on the discovery server side is this (3 devices should be trying to connect to this server )

Stats: 0.00 announces/s, 0.00 queries/s, 0.00 answers/s, 0.00 errors/s
Stats: 0.00 announces/s, 0.00 queries/s, 0.00 answers/s, 0.00 errors/s
4d65822107fcfd52 POST /v2/
4d65822107fcfd52 updateDevice in 206.367µs
4d65822107fcfd52 insertDevice in 139.371µs
4d65822107fcfd52 commit in 6.361µs
4d65822107fcfd52 POST /v2/ completed in 902.519µs 
Stats: 0.00 announces/s, 0.00 queries/s, 0.00 answers/s, 0.00 errors/s

http: TLS handshake error from xx.xx.xx.xx:41102: EOF

There are no ids printed on the server side when the debug is enabled.

Maybe you need to add the /v2/, which the default discovery servers use as well in v0.13.


instead of


That took care of some of the server errors, but the clients still cant see eachother.

Btw I got the url format from the docs

What is the proper “-listen” format?

Is it -listen=“xxx” or -listen “xxx” or -listen=":xxx" ?

Both will work. You can edit and update the docs on githib youtself.

PR is submitted for the docs. Make sure you include the trailing slash after the v2 … this bit me and it took awhile to figure out that was the issue :confused:


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.