CPU usage & network I/O with v1.8.0


Ever since updating to v1.8.0 on Windows, I’ve been seeing Syncthing suddenly starting to use 25% CPU (i.e. 1 core) more or less continuously, while performing lots of network I/O. Resource monitor shows the syncthing.exe constantly sending and receiving 22-23 kB/s for no apparent reason.

This does not happen immediately after starting the application. It usually remains quiet for a while, but once it starts, it just keeps going. The other Syncthing peers are 6 Android devices running v1.7.1.

Did you check the logs to see what its doing?

The funny thing is, it doesn’t seem to be doing anything in the logs. But I started up Wireshark and there seems to be continuous UDP traffic with the other Syncthing peers – I’ve attached an example.

capture.pcapng (2.4 KB)

I guess it’s connected over quic?

You can enable connection logging facility and see if that prints out anything interesting.

On upgrade all indexes are exchanged. That shouldn’t take long in general, but could be the culprit. Would be detectable by remote devices not being up-to-date.

Here’s a snippit of the log after enabling connection logging. I also did another capture of 5000 packets. Lots of constant UDP traffic to the other Syncthing peers. It’s now been a few days since the upgrade to v1.8.0 on my Windows PC and this is still happening, so this doesn’t seem normal.

capture 2.pcapng (527.6 KB) syncthing.log (9.3 KB)

Hard to say. Looking at the PCAP these should be QUIC packets but don’t look like it. Frankly I suspect some badness in the QUIC package…

Here’s a slightly longer log with connection logging enabled. I’m afraid I don’t know what would be interesting, though. There seem to be a lot of reconnects, but I think that’s probably normal with the Android devices, esp. on a mixed IPv6/IPv4 network.

I don’t think it’s index exchanging either. The remote devices all appear to be synchronised.

Any pointers where I could continue looking?

syncthing 2.log (51.3 KB)

Nothing suspicious there. It just seems to be reconnecting. I guess you should start by trying yo upgrade the other side to the same version, and if that doesn’t help, see if what happens if you disable quic.

So, for those who are interested: updating all clients to v1.8.0 seems to have resolved the issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.