Corrupt Files


We’re using Syncthing do sync large amount of image sequences to remote workers from our server (Windows Server 2012). Unfortunately sometimes images appear to be corrupt after syncing. The filesize is slightly different. Syncthing however reports both folders in sync. Triggering a full scan on both sides doesn’t have any effect. Any help would be greatly appreciated!


Are there android devices involved or some old (fat32 based) filesystems involved?

No Android. Our server is NTFS. It’s a RAID5 if that’s of any concern? Oh and Syncthing runs on a VM on this server, accessing the files with a network drive. The client is a Windows 10 workstation with a NTFS SSD.

I don’t think syncthing itself can corrupt files.

You could provide the output of this:

from both sides.

Also, stat outout of both files on both sides etc.

I quickly tried, but I couldn’t get it to work:

curl -H "X-API-Key: mykey" localhost:8384/rest/db/file?file=myfolderid/ELEMENTS/IO/SHOTS/0960-220/PLATES/3200x1646/0960-220_scan_L1_v001.1010.dpx

returns “no such object in the index”. I supose this is not the right way to specify the filepath?

Also what do you mean by

[quote=“AudriusButkevicius, post:4, topic:15824”] stat outout of both files on both sides etc. [/quote]?

You haven’t specified the folder id, and you need to quote the url.

still no luck. I tried

curl -H "X-API-Key: mykey" "localhost:8384/rest/db/file?folder=myfoldery&file=myfolder/ELEMENTS/IO/SHOTS/0960-220/PLATES/3200x1646/0960-220_scan_L1_v001.1010.dpx"


curl -H "X-API-Key: mykey" "localhost:8384/rest/db/file?folder=myfoldery&file=/ELEMENTS/IO/SHOTS/0960-220/PLATES/3200x1646/0960-220_scan_L1_v001.1010.dpx"

You prefixed the file name with the folder id, you don’t need to do that. You also don’t need to anchor the path with a slash I think.

You mean like this? curl -H "X-API-Key: mykey" "localhost:8384/rest/db/file?folder=myfoldery&file=ELEMENTS/IO/SHOTS/0960-220/PLATES/3200x1646/0960-220_scan_L1_v001.1010.dpx"

I tried this before, same result :frowning:

[EDIT] that works, sorry. I don’t have access to the remote computer now. But I will comeback with the output tomorrow. Thanks so much for the help so far!

Here are the outputs from server and client. client.json (1.3 KB) output_server.json (1.3 KB)

Ok. Nevermind, I’ve found the problem. It was a tool mirroring the files internally for syncthing to copy. The problem was there not with syncthing, sorry for the noise!!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.