Connect to remote server without UPnP

As I mentioned in, I have some problems when connecting to remote server.

I have a remote server. I can ssh to it. It seems to have no UPnP:

[36CSZ] 21:56:09 INFO: No UPnP IGD device found, no port mapping created (read udp4 i/o timeout)

I add nodes on both local and remote server, but both of them display each other in Disconnect status. I’ve use telnet remote_server 20000, and it seems that I can’t reach that port on my localhost. I think I should use SSH to forward remote port to my localhost. The problem is, I don’t know what to do after forwarding remote 20000 port to local.


You mean a root server? Or something else? Does it have a fixed IP?

EDIT: btw. the default port is 22000 and not 20000, see:

I’m not sure what it this? The server is a workstation on our department. I have a account on it, and I can ssh to it. I have no root permission, however. It has fixed IP, and it also has a domain name point to that ip.

Then i would use this to add the node on your local machine.

So you are in the same sub net? And the workstation is not behind a NAT router and you are not behind a NAT router? Then you didn’t need any port forward.

I can’t reach the port. I mean remote_server:22000 I’m not sure if we are in a same subnet, but we are indeed in a same ip region (140.112.*)

I don’t know what is a NAT router?

what i did with ssh for testing:

create the port forwarding ssh -L33000:localhost:22000 user@remotemachine

then for the node address in syncthing admin page


worked fine for me

I didn’t see the real problem here…

You can connect to the other machine. So just add the domain name in syncthing. You can also disable discovery and upnp and it should work.