Computer is disconnected

Version Information

Syncthing Version: v0.14.31 OS Version: Xubuntu 16.04

I have 3 computers which are synched. The synchros, till yesterday, worked nicelly This evening, I saw that one computer was not synchronized. The two other computer saw the third one as disconnected. I found the syncthing failed to launch on the third one.

Here is the log of a manuel launch:

[monitor] 22:13:19 INFO: Starting syncthing
[ZVLRD] 22:13:19 INFO: syncthing v0.14.31 "Dysprosium Dragonfly" (go1.8.3 linux-amd64) 2017-06-14 03:24:09 UTC [noupgrade]
[ZVLRD] 22:13:20 INFO: Single thread SHA256 performance is 121 MB/s using minio/sha256-simd (100 MB/s using crypto/sha256).
[ZVLRD] 22:13:21 INFO: Hashing performance with weak hash is 106.08 MB/s
[ZVLRD] 22:13:22 INFO: Hashing performance without weak hash is 121.59 MB/s
[ZVLRD] 22:13:22 INFO: Weak hash enabled, as it has an acceptable performance impact.
[ZVLRD] 22:13:22 INFO: Ready to synchronize "GX723 (xtvg-m7ap3)" (xtvg-m7ap3) (readwrite)
[ZVLRD] 22:13:22 INFO: Ready to synchronize "Dell (k8rkn-9y243)" (k8rkn-9y243) (readwrite)
[ZVLRD] 22:13:22 INFO: Send rate is unlimited, receive rate is unlimited
[ZVLRD] 22:13:22 INFO: Rate limits do not apply to LAN connections
[ZVLRD] 22:13:22 INFO: Using discovery server
[ZVLRD] 22:13:22 INFO: Using discovery server
[ZVLRD] 22:13:22 INFO: Using discovery server
[ZVLRD] 22:13:22 INFO: Using discovery server
[ZVLRD] 22:13:22 INFO: Using discovery server
[ZVLRD] 22:13:22 INFO: Using discovery server
[ZVLRD] 22:13:22 INFO: TCP listener ([::]:22000) starting
[ZVLRD] 22:13:22 INFO: Device ZVLRD26-BRM2P6X-5CQTDL2-ENQ5PDB-P53CYBK-FFRK2YK-NIYPO7M-LJ73BQJ is "aupeix-GX723" at [dynamic]
[ZVLRD] 22:13:22 INFO: Device CJXJLFV-EIZCEMA-6KPCRVT-CHWTD2B-Y4G7VGK-YPR4YJG-7G5JC6C-YMEIFQ6 is "Gramps-JujuLand" at [dynamic]
[ZVLRD] 22:13:22 INFO: Device VKRSEFS-IYEZP2A-5B62QXW-5OA2ALL-WETVYBJ-Z7ABRP4-PBS4ITT-P35MSA5 is "Dell-DM061" at [dynamic]
[ZVLRD] 22:13:22 INFO: Completed initial scan (rw) of "Dell (k8rkn-9y243)" (k8rkn-9y243)
[ZVLRD] 22:13:22 FATAL: Starting API/GUI: listen tcp bind: cannot assign requested address
[monitor] 22:13:22 INFO: Syncthing exited: exit status 1
[monitor] 22:13:23 WARNING: 4 restarts in 18.635794198s; not retrying further

I really don’t understing why it fails now. I just notice that the computer is a notepad, and if I generally disable the wifi and use ethernet, I forget it and after, when I saw it was enable, disabled it. I notice too that the address which was memorized in one conf of syncthing was the wifi used address.

Can it be the reason, and how to solve it ?

Thanks A+

[ZVLRD] 22:13:22 FATAL: Starting API/GUI: listen tcp

You’ve told Syncthing specifically to start the GUI on, port 8384. If that address isn’t available, Syncthing can’t start.

I have three computers:



aupeix-GX723 (the one which fails)

All the computers have links with each other.

I just found, but I don’t remember in which config that it refers to, address which was the one used by the wifi.

All these addresses except (which isn’t now avalaible as I disable the wifi) were avalaible.


The address was wrong in the config of aupeix-GX723, and was the address of Dell-DM061.

The reason could be this:

On the box, Dell-DM061 and Gramps-JujuLand had static address, but not aupeix-GX723

I always open Gramps-Jujuland first, as it’s my principal computer. The last day it syncs, I ought to open only aupeix-GX723, and with wifi and ethernet.

This was why I saw somewhere the address

I disabled the wifi the same day and after, syncthing, as it the address was ‘automatic’, take the address given by the box which seems to be the address of Dell-DM061 (what I don’t understand), so the address having been registered was an address which works because Dell-DM061 was not launched.

Yesterday, I launch Gramps-JujuLand and then the two other computers at the same time. And aupeix-GX723 tried to use this address which was not possible, as Dell-DM061 was using it.

Today, suprised by the fact that the address seems wrong (after your answer), I modify it in config.xml, and it works.

I’m not sure that it’s the exact reason, but it’s the only explanation I found.



Leaving it as should work equally well and reduce confusion.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.