Case issues between 2 macs

I am currently running syncthing v0.11.15 on both my MacBook and iMac. The idea being that during the day I use the MacBook and it will sync back to the iMac when I get home. However on the first day I arrived it started whining about 2 files. According to ST they are named credits.md and license.md (which they are not, they’re actual CREDITS.md and LICENSE.md). I can’t seem to get this rectified, tried deleting them on both devices, but it keeps on complaining about “no source available”. Anything I can do to get rid of these errors? I can imagine case problems between 2 different OS’ses, but between the same one? Bit weird…

Sorry about that. Removing them (from either or both side) should fix it though. Note that renaming from credits to CREDITS is not removing in this case…


As a technical aside, here’s why this happens… Syncthing is internally case sensitive, so when it sees CREDITS.md where there was previously credits.md this gets added as a new file. In a “normal” rename we then detect that the old name has disappeared, and understand it was a rename because the new contents are the same as the old contents.

However, on Mac (and Windows) when we ask the filesystem does CREDITS.md exist? it answers “yes” when there is a file called credits.md. So we keep both records. But they’re only the one file on disk. So this gets confusing for Syncthing.

Removing them and allowing a rescan to happen should clear out both records though. Then it can be re-added with the correct name.

There never has been another case variant of those files. It has been CREDITS.md from before syncthing was installed (in fact it always was). I’ve completely removed the files at both ends and restored them after a while and it’s still failing. But I’ll try again. Thanks for the reply.

Can you try to make sure that there was a rescan inbetween?

Seems that has worked, nice! Thank you all.

And 4 days later it broke again… same 2 files, without changing them. F* it.