'Can't invoke the daemon' after upgrading from 1.7-1.8.0-1

I apologise if I’m being a nuisance; I’m a Linux neophyte.

Today I upgraded Syncthing 1.7.x (can’t remember the exact version) on Manjaro (kernel version 5.8.3-2-MANJARO-ARM) running on a Pinebook Pro; I upgraded to Syncthing 1.8.0-1.

When I now start the computer, Syncthing GTK (version 1: says the following:

Failed to start Syncthing daemon. Error message: Daemon exists too fast

Please, check your installation or set new path to Syncthing daemon binary.

The path that exists - /usr/bin - actually does exist, as does ‘syncthing’ in that location.

I’ve also successfully reinstalled the application, to no avail.

Any help would be greatly appreciated as I love using Syncthing and would be a bit lost without it. Thanks in advance!

Check the logs of the service

1 Like

Thanks. I’ve not managed to find the syncthing logs, but by using Syncthing GTK I’ve seen something named ‘Daemon Output’. When I check that information, it says the following:

panic: qtls.ClientSessionState not compatible with tls.ClientSessionState

goroutine 1 [running] github.com/lucas-clemente/quic-go/internal/handshake.init.2() github.com/lucas-clemente/quic-go@v0.17.3/internal/handshake/unsafe.go:26 +0x1d0

I hope that can help. If not, I’ve tried to find where to locate the Syncthing logs and failed; I have tried to find documentation on where to locate the service logs but found nothing. Any help would be greatly appreciated. Thanks!

You have an incorrectly built Syncthing that doesn’t work. Try grabbing one of our binaries from syncthing.net/downloads, or downgrade back to 1.7.0, or wait for your distribution to release a fixed package / 1.9.0 release.


Thank you so much, @calmh! I will do that. Cheers!

1 Like

Hey @calmh! Sorry for asking, but I’ve scoured the GitHub site and found a lot of files, but…is there a guide available for a noob like myself to grab a binary and replace what I already have? Sorry.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.