Can't find the GUI (Linux)

I’ve two computers in my (home)network, 1 windows PC and 1 Raspberry pi (upgrade to Debian Stretch) I can’t reach the GUI of my raspberry syncthing and something odd is going on. When I start syncthing it shows the gui is on (Snap shot) screenshot

This is very odd, because I set the GUI to (Screenshot) I did a ‘find -name’ on syncthing, to be sure there wasn’t an other config file. Also I did a reboot of the raspberry, but it still let me use the GUI anymore.

Any ideas?

In the console we print the routable address, as you can’t access via the browser.

I’ve changed this in config.xml
(like in the docs

in the browser i use ‘localhost:8386’ or

any other suggestion?

That should work. Are you sure you are on the same machine? Do you have a firewall or proxy configured? Have you tried curl’ing that address?

syncthing on my windows computer listens to port 8080. So I shut down the windows, computer. And changed the config file on my linux raspberry to port 8080 This fires up my GUI now :slight_smile: however I still don’t understand why
Probably it’s something in my network. (I have temp. the firewall off) ty for your suggestions. I will reply if I find out more

Check your hosts file to see if you have localhost or localhost Your screenshot shows the, not To use you hosts file would show either or the second line, or change your st config.

I’m dealing with the exact same problem.
Worked fine on both windows and raspberry but suddenly the raspberry isn’t accessible anymore. Not direct on the same machine and not in the network.

I’ve found the solution If you want to see the GUI of Syncthing, running on a headless Raspberry, on your Windows (or any other) computer in the same network, you can access it by it’s internal IP-address for me it’s
but in most new standaard configurations it will be something like http://192.168.178.XX:8384
(you have to find out XX in your network. One way to find it, is in your modem. most modems has as web GUI) I’m not sure why it’s not accessible anymore by localhost

Maybe it was after Windows10 update what caused it.

1 Like

Thank you, that helped me out :grin:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.