Can't change or reset password for GUI


#1

Since I forgot my password, I removed the “user” and “password” elements from the config.xml file.

The GUI then warns me, that there is no password set, which is to be expected.

But if I enter a new user/password combination in the GUI and save it, the config.xml file isn’t updated, although I don’t get any error messages. I still get the warning and don’t need a password to access the GUI.

I tried to restart Syncthing in the GUI and directly using systemctl.


(Jakob Borg) #2

Odd. Did you make the config.xml read only for the syncthing user when you made the manual change, maybe?


#3
# ls -la
total 60
drwx------ 3 syncthing users  4096 Feb  8 14:33 .
drwx------ 3 syncthing users  4096 Dez  8  2016 ..
-rw-r--r-- 1 syncthing users   615 Dez  8  2016 cert.pem
-rw------- 1 syncthing users 19830 Feb  8 13:02 config.xml
-rw------- 1 syncthing users   825 Feb  8 14:30 csrftokens.txt
lrwxrwxrwx 1 syncthing users    19 Feb  8 14:28 https-cert.pem -> /etc/ssl/xxxxx.crt
lrwxrwxrwx 1 syncthing users    27 Feb  8 14:28 https-key.pem -> /etc/ssl/private/xxxxx.key
drwxr-xr-x 2 syncthing users 20480 Feb  8 14:30 index-v0.14.0.db
-rw------- 1 syncthing users   288 Dez  8  2016 key.pem

It works fine now. No idea what went wrong. I replaced the GUI part of the config.xml with one from another system. After that I could reconfigure the GUI settings in the GUI itself. Maybe a typo. The syncthing user had/has access to the file.

Another idea is, that I replaced the SSL certificate with my own. But the link target was empty and Syncthing wanted to recreate it’s own certs, but couldn’t because of the links…

Anyway, everything works fine again. :slight_smile: