Cannot connect to GUI

Hello, after the upgrade to v0.14.11 I can’t open the GUI remotly. I tried reinstalling Syncthing but it didn’t work… On my Raspberry Pi, it seems to listen to the address I have chosen but still no connection from outside possible.

I really don’t know what else I could do to fix this problem.

Port 8384, which is the GUI, is only listening locally.


1 Like

I configured the config.xml to this: and it also worked in the version before. On my Windows client the GUI works, I didn’t try to access it remotly.

That looks fine, but it’s not what’s running in the screenshot above.

Should I make a clean install of syncthing? What files/folders do I have to delete in order to do this?

I think you just need to make sure you are editing the config file that Syncthing is actually using (see syncthing -paths), that Syncthing has been restarted with the new config, and that it’s running as the user you think it is. Reinstalling won’t resolve this issue.

I looked up the paths, they were all correct, I also changed permission to 777 for the .config folder but still no connection. I added my Pi on my other client and in terminal I get device rejected and something with an EOF error. This message comes in regular intervals.

I got it to work, somehow not my “jim” user started syncthink but root. So I changed the config from root user and it works now. Thank you for your tip with the -paths! Have a nice evening.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.