Cannot connect devices in version v0.11.13, Linux (64 bit)

I´m using syncthing from the first time. After installing an clean version of fedora 22 on one of my notebooks its not possible to connect devices with v0.11.13, Linux (64 bit). IP-adress of the target devices could not be found. The target devices uses android and fedora 22 too. They are in the same lan.

Here is the logfile from the rebuilt notebook:

[monitor] 09:01:14 INFO: Starting syncthing [DKO4Q] 09:01:15 INFO: syncthing v0.11.13 (go1.4.2 linux-amd64 default) unknown-user@syncthing-builder 2015-07-05 17:44:55 UTC [DKO4Q] 09:01:15 INFO: My ID: DKO4QXO-AGD6DXO-XAZZLIQ-YVNTUAW-GDQZ5JF-M7OV7PH-ZDZGZFF-FYQRQA7 [DKO4Q] 09:01:15 INFO: Database block cache capacity 13815 KiB [DKO4Q] 09:01:15 OK: Ready to synchronize schule (read-write) [DKO4Q] 09:01:15 OK: Ready to synchronize default (read-write) [DKO4Q] 09:01:15 INFO: Starting web GUI on http://127.0.0.1:8384/ [DKO4Q] 09:01:15 INFO: Completed initial scan (rw) of folder default [DKO4Q] 09:01:16 INFO: Completed initial scan (rw) of folder schule [DKO4Q] 09:01:17 INFO: Starting local discovery announcements [DKO4Q] 09:01:17 INFO: Starting global discovery announcements [DKO4Q] 09:01:17 INFO: Device S7WLP2N-TYTJWMK-4QKJ6AB-IAFP7F3-TIUB67M-CDDXKPX-6GTR5HI-DRVECQT is “papa” at [dynamic] [DKO4Q] 09:01:17 INFO: Device DKO4QXO-AGD6DXO-XAZZLIQ-YVNTUAW-GDQZ5JF-M7OV7PH-ZDZGZFF-FYQRQA7 is “mini-tux” at [dynamic] [DKO4Q] 09:01:17 INFO: Device GF2SXFB-EQAIODQ-KEWNSG7-3G4INSX-6JEKS5D-UXS22MI-FLD4UZT-HQLKPQD is “mobile” at [dynamic] [DKO4Q] 09:01:17 INFO: Starting usage reporting [DKO4Q] 09:01:17 INFO: API listening on 127.0.0.1:8384 [DKO4Q] 09:01:27 INFO: No UPnP device detected

What could be the reason for it. Previously syncthing worked fine :frowning:

Do the other two devices connect to each other?

I think the firewall of fedora blocks the multicast or broadcast packets Syncthing uses for local discovery.

1 Like

I didn´t try to connect my mobile with the other device. But I will check it soon. What I have to do withe the firewall settings? Former it was not necessary to change this settings.

added 22000/TCP and 21025/UDP in firewall settings … added :8384 in /etc/hosts, but nothing happens. I still cannot connect devices.

If this is on LAN, then adding 21025/UDP is not enough, as you have to explicitly allow multicast vendors.

As a test, you can temporarily disable the firewall to make sure it’s not the culprit.