Can one stop syncthing from synchronizing permissions?

I am synchronizing some web pages (a wiki actually) and it works pretty well except that sometimes I edit files as myself (‘chris’) whereas at other times files get created by the web browser (‘www-data’). This causes a problem with syncthing which runs as user ‘chris’. It tries to chmod all the files but fails where the files are created by user ‘www-data’.

Is there a way to tell syncthing not to try and chmod files? I seem to remember that there is a way to do this but I can’t remember how to do it now. The files are actually synchronized but I get errors for the ones where it can’t chmod them.

… and, no, I can’t run the web browser as ‘chris’ that produces all sorts of nasty problems.

There’s an ‘ignorePermissions’ advanced setting IIRC

Aaaaahhhh!!! Oops, I asked almost the same question several months ago. Yes, the ‘Ignore Permissions’ option does what I need. For some reason it had got unchecked.

Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.