Bandwidth not fully used on second node


I am new to syncthing and I love it.

Everything worked fine at home while syncing in lan. But now I have another node at my friends place.

Problem: Node A (my node) is working fine. My upload bandwidth could be 10Mbit but I limited it to 600kbit.

The bandwidth from node B (friends node) could be 40Mbit and is limited to 20Mbit.

Connection from node A to node B is at its limit (600kbit) But the connection from node B to node A is roughly 500kbit. So it is not using the full bandwidth limit.

The cpu and ram is not stressed by syncthing. Both are using under 10% after they scanned everything. We have no VPN.

Facts: Both same Hardware (Xeon E3-1225,24Gb ram), Openmediavault, Syncthing version 12.3 (also tested with 11.x), A–>B working fine, B–>A slow only working with 20%-25% of limitation

Thanks for your help :wink:

Sorry, but your explanation is too hard to understand. Don’t understand this A to B, B to A business, and this could be 40, but limited to 20, etc.

You should check if you are connected directly or if you are connected via a relay. (If it says Relayed via on the remote device details box)

If it’s via relay, relays usually have limits, and you should setup port forwarding to be able to connect directly.

ok sorry for the bad explanation.

So is it necessary that both server have a “static” ip?

Because I have a static ip but my friend not. My bandwidth to him good, but his to mine is bad.

You don’t need a static IP, but either you have to have port forwarding or UPnP on one of the sides to be able to connect directly.

If you are both blocked by a router, the only way to connect will be via relay, which means degraded speeds.

His port was not forwarded. maybe now everything will work.

Thanks for your help. I will check it tomorrow and give an update.

It’s enough to have ports forwarded on one side. As I said, make sure you are not connecting via a relay.

yes. Now all needed ports are forwarded at both sides. Now they need time to share the databse table. it is 3gb. this will take a while.

Everything works fine now. Opening all needed ports manually worked better than using Upnp.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.