Android 0.4.9 missing repositories


I installed 0.4.9 and I am missing my repositories. The nodes are there but after installing it did not show any repo. So I added the same repos to make sure. I restarted and it is still not showing any repository whatsoever.


Here is some logs that might help

You’re not alone. I have the same problem with 0.4.9. The problem is posted over on the Syncthing-Android issue tracker. The developer of the Android app ( @Nutomic ) is working on a fix.

By the way, if you open the Web GUI on your Android device, you should see that your repos are still there. The bug appears to be limited to the repos screen on the Android app.

I just tried the latest .5 and I am still missign repos ;( The web gui shows that the repo I created is there. When I created first time (after probably 10 crashes) It showed in the gui. I restarted it , now the gui does not show the repo. I can see it in the Web gui but the repo is not editable in the web gui.

Missing repos should be fixed in 0.5.0-beta2 (at least it is to me).

Do you see any pattern in the missing repos? eg a certain setting that may trigger it? (maybe wait with testing until I fixed the crashes)


I cant tell, it is hard because I am getting alot of crashes so hard to test.

Initially it gave me headache creating repos claiming that it had doub id. Anyway I managed to delete all in the web gui and then I recreated my main repo. It showed it in the gui next time. But it crashed once since then it is missing the repo in the gui.

Yeah as I said, best go back to 0.4.9 until I fixed the crashes. I’m sorry :frowning:

Edit: Note that the fix may take a little longer. I’m going to Finland on Thursday and I’m way too excited to get any programming done :smiley: