All files and directories reported as Local Additions with 0 Bytes


I’ve created a “Send Only” folder in a Windows 10 machine. I’ve shared it as a “Receive Only” folder in an Ubuntu 18.04 machine. Both folders are in external USB drives both formatted in NTFS.

Files have been copied correctly and Global and Local States are the same. But in the Receive Only folder in Ubuntu I see all the files and folders listed as “Locally Changed Items” (119.334 files + 3.697 folders = 123.031 items), but with 0 Bytes of changes. I guess that it is related to some kind of different permissions, ownership or some limitation using ntfs in ubuntu with syncthing.

Using “Revert Local Changes” starts a scan, but it ends on the same place. Any ideas?



PS: I’m gonna donate to the project for sure. I’ve been using it for a week and besides this (small) issue, it worked so great so far!


This is pretty much guaranteed to make Syncthing very confused about permissions and such. Setting ignore permissions might help, but might not be the only problem. Rather untested setup. :wink:

Ah no, not untested: I use ntfs (with ntfs-3g) under ubuntu’s parent debian since like forever with Syncthing with ignored permissions (dual boot laptop, though I can’t remember when I last booted windows).


Thanks! Ignore permissions worked. Maybe the comment about FAT could be improved to add NTFS on Linux as also recommended?

Anyway, such great and quick support, thanks!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.