100% sync. Paired comp stuck at 100% 2.62MB to go.

I have one computer that shows all UP TO DATE for all folders. However, on the paired computer, the first computer under “Remote Devices” has been showing Syncing 100% 2.62MB to go for about a week now.

I wonder why the second computer is stuck with the strange combo of 100% complete, but 2.62 MB to go.

Nothing in the syncthing error log.

The 100% 2.26MB combo should not be possible, as the percentage number is rounded down:

$scope.completion[device]._total = Math.floor(100 * (1 - needed / total));

Google tells me javascript uses 52bits for the base part of the number, so unless I am not understanding computer numbers (my brain works in scientific base10 :stuck_out_tongue: ) you’d need to have 2.26MB*2^52 ~ 10^10 TB total data to get “internal rounding” to take effect, which I guess isn’t the case. In general we are closer to the limit, e.g. if just 1B is out of sync, a total of ~4500TB is enough to reach that limit - still not that bad for a non-critical number (45x max reported data). So I am at a loss about that.

About the broader issue of being up-to-date but still syncing: If you are on a version <= 0.14.40 folders being up-to-date but devices being syncing could be due to different ignore patterns on the two devices. If you are at 0.14.41 that problem is solved, so what you see may be the influence of a (potentially disconnected) 3rd device or a bug. Once https://github.com/syncthing/syncthing/pull/4559 is merged the first diagnosing step will be simple, hopefully this will be in the first release candidate of 0.14.43, which is due (unless problems come up) in about a week.

Which Syncthing version?


I went through and made sure all my ignore files were the same and I upgraded to 0.14.14, and sure enough the problem went away. I realized the scope was wider than I first thought. It wasn’t just one folder, it could be ~any~ ignore file in any of the multiple folder syncs.

That said, your calculation also intrigues me. Here is a screenshot of the original situation:


I assure you I don’t have 10^10 TB of storage! Because the problem went away, I assume it was an ignore problem, but it’s good to think through the math like you did.

Rounding down completion percentage on remote devices was introduce some versions ago (if I had to venture a guess it would be something like 0.14.35), so it looks like everything is fine. With 0.14.41 ignores will be taken care of as well.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.